Mount Windows Shared Drive on Jetson TX2

I am able to mount this external shared drive using the Jetson desktop file manager UI. But I can’t figure out how to do it on the command line so that I can include it in a startup script.

I’ve tried many different variations similar to this and this is the same shared drive I’m mounting with the UI.

sudo mount -t ntfs-3g -o username=ocUser //10.0.0.240/kukaD /mnt/smb
ntfs-3g: Failed to access volume ‘//10.0.0.240/kukaD’: No such file or directory

ntfs-3g 2015.3.14AR.1 integrated FUSE 28 - Third Generation NTFS Driver
Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright © 2005-2007 Yura Pakhuchiy
Copyright © 2006-2009 Szabolcs Szakacsits
Copyright © 2007-2015 Jean-Pierre Andre
Copyright © 2009 Erik Larsson

Usage: ntfs-3g [-o option[,…]] <device|image_file> <mount_point>

Options: ro (read-only mount), windows_names, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

Thanks,
Mike

Your device argument to mount looks like a network share, but ntfs-3g driver looks like it wants a local block device. When you have a windows fileshare you might use -t cifs independantly from what filesystem your blockdevice under windows has.
When you can mount the device with a UI, than it may show in the output of

mount
(thats with no arguments)
what device and what „driver“ you might need.