Mounting all.img

My jetson seemed to had died. Before starting my efforts to safe it i figured i would make a complete clone from the device to be able to go back to this point.
Using the command: sudo ./nvflash --rawdeviceread 0 3849216 all.img --bl ardbeg/fastboot.bin --go (source: http://elinux.org/Jetson/Cloning)
afther finding out, trough the uart that de device still boots i was able acces my terminal (but this was afther i restored an old img).
restoring the complete image takes about 4 hours, so i would like to mount my all.img on my pc so i can acces the filesystem and recover my files.
i tried sudo mount -t ext4 -o loop all.img /mnt (source: http://elinux.org/Jetson/Cloning)
however this gives me the error: wrong fs type, bad option, bad superblock on /dev/loop1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

in the syslog:
[330684.197109] EXT4-fs (loop1): bad geometry: block count 3670016 exceeds size of device (152061 blocks)

Can someone help me mount the all.img (15 GB) or extract my files from the .img without putting it pack on the jetson?

fdisk -l all.img

Disk all.img: 15.8 GB, 15766388736 bytes
255 heads, 63 sectors/track, 1916 cylinders, total 30793728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk all.img doesn’t contain a valid partition table

Restored the latest img. connected uart cable (rs232) to windows desktop.
With putty I used: cat (filename) and copied the outputted text into new text file.
So this solved my issue with the lost files, but my jetson still wont connect to properly to any display but I think that’s for another topic.

The copy of the entire Jetson is not a mountable file system…loopback mount example from the article (http://elinux.org/Jetson/Cloning) mentions “–read 9”, chosen becaise ID 9 of the flash.cfg table using this section for system.img. This portion is the actual user data for mounting on loopback. Other parts are more or less binary data which isn’t normally visible on the rootfs.

NOTE: On my R21.4 flash flash.cfg has system.img with ID 12.