Mouse Not working after the Nvidia driver installation

Test setup

cisco UCS C240
vSphere 6
Xendesktop 7.6

Soon after installing nvidia driver on Windows 7 VM Mouse pointer is dissapearing and it working fine on RDP.
But the real problem is one of our in house gaming app is not able to detect the mouse when launched on the VM.
Appriciate any help.

Thanks.

This is due to the way that the remoting protocol detects the local mouse position and transmits it from client to VM. The best source for information on the issue is from Citrix in this case.

It’s also dependent on the way in which the game engine detects the mouse position. Different engine’s behave differently so for example Cryengine will detect the mouse correctly in the VM, but Real Virtuality (ARMA) will not. I’ve seen Borderlands 2 (Unreal Engine 3) and Elite Dangerous (proprietary game engine) working in a Citrix environment, as in the video below.

https://www.youtube.com/watch?v=gaJypGGSP68

With what you have right now, your options are

  1. Pass the mouse hardware directly to the VM
  2. Use a controller such as Xbox or PS passed directly into the VM
  3. Use the GRID SDK to develop an in house remoting solution (This is how our own GRID gaming on SHIELD is built).

Hi Jason,

Thanks for the suggestion. But i believe this is something to do with VMware or Nvidia driver. Because i created a new Windows 7 VM and tried to run the game without installing the Citrix VDA. Still i am having the same issue. Have been trying this issue for last two days but still no luck. Hoping someone will be able to show some light here :)

Riff

You’re still connecting remotely though, and so using a remoting protocol, just in this case you’re using something different to Citrix.

It’s all connected to the remoting protocol and how mouse position in at the client is reported into the VM.