mpif90 test failed bash !

I am trying to configure Chemical Transport Model- MOZART. During configuration step, the model check the mpif90 script by compiling a short MPI program.
When I issue the configure commands it shows the following errors:
(I installed PGI community edition 17.4 Fortran compiler in Fedora-26, 64-bit operating system.)

It directly shows following output in terminal after issing the commands:

‘‘model: Undefined variable.’’

And in log file:


The operating system is : LINUX

gmake is in the execution path

mpif90 filepath : /usr/lib64/mpich/bin

Portland Group pgf90 is in the execution path

pgf90 test successful

bash! mpif90 test failed bash! ‘’.

This shows that mpif90 compilation test has failed. Can someone help me to solve this problem?

It will take some time to get the Mozart sources.
I typically configure with

setenv PGI /opt/pgi
set path=($PGI/linux86-64/17.10/bin $PGI/linux86-64/2017/mpi/openmpi/bin $path)

setenv CC mpicc
setenv CXX mpic++
setenv FC mpif90

setenv CC pgcc
setenv CXX pgc++
setenv FC pgfortran

./configure --help

I run to determine what switches and environment variables I need
to define. Do I need “–enable-c++”" or “–enable-fortran”

Once all is defined I run

./configure --prefix=/path/to/final/install

and any failures, I look at configure.log for answers.