Ms Office in Wine Corruption

Hi,
I have in my pc: Opensuse Tumbleweed, kde 4.17, kernel 5.3.XX and the last nvidia graphics drivers,

I have Ms Office 2013 installed by wine. It’s working perfectly, However, I got a graphic corruption when I resume my pc after suspend. I got that colors change in the windows, for example the “white paper” in word to an aleatory color (red, green, blue…). Similar problems in Excel and PowerPoint. Is there any posibility to fix it?

It must be a nvidia driver problem, because I have a netbook without problems with intel driver.

Thanks

This is fixed with a new feature in the driver:
http://download.nvidia.com/XFree86/Linux-x86_64/435.17/README/powermanagement.html
but this is not yet set up by distributions and rather fiddly.

Hi,
I tried to make it work by myself, without successs.

I install the scripts and enabled the services but my computer doesnt get the suspend status. It remains in a loop and I finally have to reset it.

When is it work propertly? I consider it a big problem in Linux driver.

Thanks

It’s working for me but I had to change the provided script:
https://devtalk.nvidia.com/default/topic/1056541/linux/gnome-shell-crashes-and-rendering-problems-on-xserver-with-430-26/post/5360693/#5360693

it’s not working either. These are my steps:

install /usr/share/doc/packages/x11-video-nvidiaG05/nvidia-suspend.service /etc/systemd/system
install /usr/share/doc/packages/x11-video-nvidiaG05/nvidia-hibernate.service /etc/systemd/system
install /usr/share/doc/packages/x11-video-nvidiaG05/nvidia-resume.service /etc/systemd/system
install /usr/share/doc/packages/x11-video-nvidiaG05/nvidia /usr/lib/systemd/system-sleep/
install /usr/share/doc/packages/x11-video-nvidiaG05/nvidia-sleep.sh /usr/bin



systemctl enable nvidia-suspend.service
systemctl enable nvidia-hibernate.service
systemctl enable nvidia-resume.service

echo "options nvidia NVreg_PreserveVideoMemoryAllocations=1" >  /etc/modprobe.d/50-nvidia-suspend.conf
(and I replace the script)

I got a “screen lock” with “systemctl suspend”. If i execute “/usr/bin/nvidia-sleep.sh “suspend”” I got a new loop.

Any Ideas?

PD /usr/share/doc/packages/x11-video-nvidiaG05/ is the scripts location in opensuse rpms.
PD2 I forgot to say I have a 1050 ti

Please test this:
Switch to vt
log in
run ‘sudo systemctl suspend’
resume
switch to X

Please run nvidia-bug-report.sh as root afterwards and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Also make sure /usr/bin/nvidia-sleep.sh is executable.

I tried again and now works!! Maybe i fail replacing the file. I don’t know.

I did some test and:
-Office in wine works without corruption.
-Vmware fails anyway after suspend. I have to desactivate 3d acceleration (I dont mind)

Thanks for the tips!

PD I think Nvidia should work in this and enable this by default

I’d call it a dirty hack, instead.

They seem to blame the way kernel handles suspend:

…but then why also VT-switch to another X server and back to the first one exposes the exact same problem, which cannot be mitigated by that hack, and nvidia proprietary driver is the only one exposing the issue?

Maybe it a dirty hack, but If it works, Its enough for me.

What I don’t undestand why Nvidia cards have this problem only in Linux In windows works perfectly.

PD. With this hack, Sometimes Colors fails in Office too.