MSI Laptop Ubuntu 21.04

Hello, my nvidia card is not working in a way similar to mentioned in this forum before, but what I tried from suggestions here didn’t help.
When I try open nvidia-settings in terminal - it opens but I see errors in terminal:

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system
(nvidia-settings:4457): GLib-GObject-CRITICAL **: 14:40:00.081: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 14:40:00.085: PRIME: Requires offloading
** Message: 14:40:00.085: PRIME: is it supported? yes
** Message: 14:40:00.112: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 14:40:00.112: PRIME: on-demand mode: "1"
** Message: 14:40:00.112: PRIME: is "on-demand" mode supported? yes

Port HDMI is not working (so external display/TV not detected)

I have MSI laptop GF75 Thin 10UEK with Ubuntu 21.04
I tried UEFI boot mode without CSM - but ubuntu hangs after booting with just empty desktop/wallpaper image over screen and doesn’t work.
I tried adding pci=realloc to /etc/default/grub & update-grub & reboot
still same issue.
I have no “above 4G decoding”/“something BAR” in my UEFI settings.
nvidia bug report attached
nvidia-bug-report.log.gz (830.3 KB)

And here is my grub file, just to make sure I am doing this right:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
pci=realloc

The change to grub config is incorrect. Remove it from the end, the change the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=realloc"

and run
sudo update-grub

Thank you for reply!
I tried your suggestion and had same symptoms as when I switch from UEFI CSM to just “UEFI”.
After that I found my ubuntu is not running with Wayland.
Somewhere I found some more param to make it work:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvidia-drm.modeset=1 pci=realloc”

So now I am able to login with both “non CSM” UEFI and pci=realloc
And Ubuntu is now running woth Wayland
But issue remains - same errors:

nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

nvidia-settings
ERROR: Unable to find display on any available system
(nvidia-settings:4250): GLib-GObject-CRITICAL **: 17:41:26.729: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

So something is still wrong. Should I now regenerate nvidia bug report or old is fine to check?

Please create a new nvidia-bug-report.log

Here it is:
nvidia-bug-report.log.gz (1.7 MB)

Please disable secure boot.

It was always disabled, otherwise it was impossible to install linux for me.
Just in case here is how my uefi/bios settings look like:



PS Only difference now it’s just UEFI without CSM

Dmesg says:
[ 0.000000] secureboot: Secure boot enabled
Please check “secure boot mode” or other settings until
sudo dmesg |grep secure
returns that secure boot is disabled.

Checked again and yes it was enabled, probably was reset when I changed UEFI CSM to UEFI.
And now it works! Thank you!
I can see my desktop on TV over HDMI
but sound remains on laptop, not on TV.

Is this issue somehow related to video card also or I should keep searching about sound issue somewhere else?

You just need to switch the output to the tv in gnome control center. Otherwise, please create a new nvidia-bug-report.log.

Thanks a lot, yes in audio settings there was an output option “HDMI”

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.