.mtd files corrupted, please help nvidia

Hello,

I recently bought 2 Jetson Nano Dev Kits for a project in computer vision. I would like to install Deepstream 4.0 on them. The best way I’ve found so far of doing this is to install through the NVIDIA sdkmanager. However, when I select Host machine (18.04 Ubuntu running on an x86 AMD processor) and Target (Jetson Nano Dev Kit) and select the Download only install later option, I get the following error each time:

0:45:26 INFO : null
10:45:26 INFO : Bzip2 Patch Setup In Target Image : download ‘Bzip2 Patch Setup In Target Image’ success
10:45:26 INFO : install ‘Bzip2 Patch Setup In Target Image’ Skipped
10:45:26 INFO : CUDA Toolkit for L4T : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb
10:45:26 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb
10:45:26 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb
10:45:29 INFO : cuDNN on Target : Found file /home/marcin/Documents/Ordino/nvidia/download/libcudnn7-dev_7.5.0.56-1+cuda10.0_arm64.deb with correct checksum, skip downloading.
10:45:29 INFO : TensorRT on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb
10:45:30 INFO : Drivers for Jetson TX1/Nano : Found file /home/marcin/Documents/Ordino/nvidia/download/Jetson-210_Linux_R32.2.0_aarch64.tbz2 with correct checksum, skip downloading.
10:45:30 INFO : Drivers for Jetson TX1/Nano : download ‘Drivers for Jetson TX1/Nano’ success
10:45:30 INFO : install ‘Drivers for Jetson TX1/Nano’ Skipped
10:45:31 INFO : TensorRT on Target : Found file /home/marcin/Documents/Ordino/nvidia/download/libnvinfer-dev_5.1.6-1+cuda10.0_arm64.deb with correct checksum, skip downloading.
10:45:31 WARNING : CUDA Toolkit for L4T : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:31 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:31 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:34 WARNING : TensorRT on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:36 WARNING : CUDA Toolkit for L4T : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:36 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:36 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:38 INFO : TensorRT on Target : Found file /home/marcin/Documents/Ordino/nvidia/download/libnvinfer-samples_5.1.6-1+cuda10.0_all.deb with correct checksum, skip downloading.
10:45:38 INFO : TensorRT on Target : Found file /home/marcin/Documents/Ordino/nvidia/download/tensorrt_5.1.6.1-1+cuda10.0_arm64.deb with correct checksum, skip downloading.
10:45:38 INFO : TensorRT on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/python-libnvinfer_5.1.6-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/python-libnvinfer_5.1.6-1+cuda10.0_arm64.deb
10:45:39 WARNING : TensorRT on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:41 WARNING : CUDA Toolkit for L4T : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:41 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:41 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:43 INFO : CUDA on Host : Found file /home/marcin/Documents/Ordino/nvidia/download/cuda-repo-ubuntu1804-10-0-local-10.0.326-410.108_1.0-1_amd64.deb with correct checksum, skip downloading.
10:45:43 INFO : CUDA on Host : download ‘CUDA on Host’ success
10:45:43 INFO : install ‘CUDA on Host’ Skipped
10:45:43 INFO : TensorRT on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/python-libnvinfer-dev_5.1.6-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/python-libnvinfer-dev_5.1.6-1+cuda10.0_arm64.deb
10:45:44 WARNING : TensorRT on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:46 WARNING : CUDA Toolkit for L4T : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:46 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:46 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:49 WARNING : TensorRT on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:51 WARNING : CUDA Toolkit for L4T : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:51 ERROR : CUDA Toolkit for L4T : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
10:45:51 WARNING : CUDA Toolkit for L4T : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb failed, retrying 1…
10:45:51 INFO : CUDA Toolkit for L4T : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb
10:45:51 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:51 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
10:45:51 WARNING : cuDNN on Target : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed, retrying 1…
10:45:51 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb
10:45:51 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:51 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
10:45:51 WARNING : cuDNN on Target : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb failed, retrying 1…
10:45:51 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb
10:45:54 WARNING : TensorRT on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:54 ERROR : TensorRT on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
10:45:54 WARNING : TensorRT on Target : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb failed, retrying 1…
10:45:54 INFO : TensorRT on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb to /home/marcin/Documents/Ordino/nvidia/download/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb
10:45:57 INFO : TensorRT on Target : verifying checksum of /home/marcin/Documents/Ordino/nvidia/download/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb
10:45:57 INFO : TensorRT on Target : download /home/marcin/Documents/Ordino/nvidia/download/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb successfully, checksum is correct

I have seen some other posts suggesting that this may be due to an update to bzip2 and I have tried the solutions offered in that post, but they did not work. I have also seen a solution suggesting I should download through the eth0 connection however, in ifconfig in 18.04 there is no eth0 as it has been renamed to

enp30s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.63 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::429c:8691:75d:ebf7 prefixlen 64 scopeid 0x20
ether 88:d7:f6:c4:ea:79 txqueuelen 1000 (Ethernet)
RX packets 39630 bytes 54612974 (54.6 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 10226 bytes 1588737 (1.5 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device memory 0xf7400000-f741ffff

Nvidia, please help me solve this, as I cannot use the Nanos without the Deepstream 4.0

Hi Molloch, can you check something to help us debug this? Please download this file and let us know it’s MD5 hash:

https://developer.download.nvidia.com/sdkmanager/sdkm-config/Jetson/Linux/sdkml2_jetson_linux.json

(MD5 hash should be 2f2b77b84872a1033973d3cc817e9859)

In the meantime, you can re-try running SDK Manager, it may work while we are investigating. Thanks.

Hi,

I have a similar problem installing on Acer laptop with Ubuntu 18.04 for Jetson Nano Developer kit. I downloaded sdkml2_jetson_linux.json file and checked check sum is: 2f2b77b84872a1033973d3cc817e9859 - what you need. Errors in the logs are the same:

DETAILS TERMINAL
Component Name: All
Message Type: All

Filter text here…

17:48:41 INFO : null
17:48:49 INFO : Bzip2 Patch Setup In Target Image : download ‘Bzip2 Patch Setup In Target Image’ success
17:48:49 INFO : install ‘Bzip2 Patch Setup In Target Image’ success
17:48:51 INFO : CUDA Toolkit for L4T : Found file /home/levon/Downloads/nvidia/sdkm_downloads/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb with correct checksum, skip downloading.
17:48:51 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb to /home/levon/Downloads/nvidia/sdkm_downloads/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb
17:48:56 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:49:01 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:49:06 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:49:11 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:49:16 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:49:16 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
17:49:16 WARNING : cuDNN on Target : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed, retrying 1…
17:49:16 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb to /home/levon/Downloads/nvidia/sdkm_downloads/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb
17:50:21 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: DevZone get download url failed: Error: socket hang up.
17:50:26 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:50:31 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:50:31 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
17:50:31 WARNING : cuDNN on Target : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed, retrying 2…
17:50:31 INFO : cuDNN on Target : start to download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb to /home/levon/Downloads/nvidia/sdkm_downloads/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb
17:51:36 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: DevZone get download url failed: Error: socket hang up.
17:51:41 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:51:46 WARNING : cuDNN on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
17:51:46 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure
17:51:46 ERROR : Flash skipped due to component(s) download/install failure

Thanks

Levon

Hello Dusty,

Thanks for your quick response.
I have checked the hashsum and it is the following:
2f2b77b84872a1033973d3cc817e9859 sdkml2_jetson_linux.json
which looks to be correct.

I have also retried several times and still get the following errors:

13:47:09 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
13:47:10 ERROR : CUDA Toolkit for L4T : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
13:47:10 ERROR : cuDNN on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libcudnn7-doc_7.5.0.56-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
13:47:11 ERROR : TensorRT on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/python-libnvinfer_5.1.6-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
13:47:12 ERROR : TensorRT on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/python-libnvinfer-dev_5.1.6-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.

Please help!

OK, thanks Molloch and Levon. We have found a 403 issue with the package tokens coming from the server and are working to identify the root cause. Will let you know when a fix has been implemented. Thanks for your patience as we resolve this.

Hi Dusty,

That’s good to hear it’s not a problem with my machine or network.

Looking forward to the fix, please keep me updated.

Best,
Molloch

I’m getting the same error

Hi Dusty,

Maybe this will help.

Since it was a 403 error, I tried with 2 different developer accounts. One of them has access to the Transfer Learning Toolkit and the other does not. Both accounts encounter the same .mtd file is corrupt error.

Does anybody have an NVonline account I could try with?

Hello Dusty,

same issue here! Thanks for keeping us updated.

Best,
Pierre

Hi All,

I have managed to find a workaround for the meantime.

What you need to do is download each .deb file in the error messages manually (via the link in the error message) into the download folder. Make sure you are logged into NVIDIA developer zone to access this.

The problem seems to be in some zipped .mtd file so the .deb files in the error messages should work fine.

This will take several tries of restarting the download. Eventually, once you have all the files in the download folder, when you restart the sdkmanager and select download and flash, the download will complete very quickly and you’ll be able to advance onto the flash process, which should also work.

This worked for me and I have successfully flashed my Jetson Nano. I can’t find any of the flashed software on it so far, but I’ll continue looking lol.

Thanks Molloch, appreciate it - we are working to get this resolved as soon as possible, and I have passed along your info to our team shall it provide them a hint as to the root cause of the issue.

@Molloch did you ever find the software that you flashed on your nano?

Any news on when we can expect a solution? I am still getting corrupt downloads through the SDK Manager.

I am getting the same error.
Is there any update on this issue?
Thanks!

You can use my hacky workaround for the time-being. It does work but it just takes a few times restarting the sdkmanager to download the .deb files in the error links.
You also have to download two .csv files, you will see them in the errors.

[quote]

I am getting the same error.
Is there any update on this issue?
Thanks!

We’ve rolled out an update to the SDK Manager client that addresses the corrupt MTD issue. Log into SDK Manager, and you will see a prompt to upgrade to version 0.9.14 - click continue, enter your sudo password, and the client will self-update. Let us know if you still encounter problems.

We are also updating the SDK Manager binary installer on the website, but for now use the self-update feature.

Hi Dusty,

Unfortunately there is still a problem. After updating the sdkmanager and removing the config files int the hidden folder, I am still unable to install the sdk components on the Jetson Nano. I have attached a picture of the error I am getting.

EDIT: Never mind, checked the ifconfig on the Nano and it had somehow changed from the default.

Everything works now. I think we can close this thread.

Many thanks Dusty, I could flash my Jetson TX2.