Multi GPU Mining + Ubuntu

Running into issues with 2 of the 9 mining rigs I run. They’re the oldest of the bunch. Both are/were running 8 CMP 30HX. Both were working fine until last week when an automated update and reboot. At the time of the reboot, they were using the driver version 470.129.06, both were running different versions of kernel 5.4.0-91 and 5.4.0-105. The update, updated their kernels to version 5.4.0-122.

After the update, the devices are found but are unusable. The kernel sees them, and so does nvidia-persistenced, which is enabled/started at boot. The command nvidia-smi however, claims no devices found.

In the process to correct, I backported to their latest working kernel versions, but no luck, same results. I decided to test my luck with the latest kernel and Nvidia drivers, with worse results.

I am currently running Nvidia, 515.48.07 on kernel 5.4.0-123-generic.

I am unable to run nvidia-smi while using nvidia driver versions 495+ regardless of what kernel version I am running.

I’ve attempted to install the drivers via apt repository and manually via .run driver files. Manually installed drivers were sourced from

The repo I am using to install the drivers from is :

I’m new on the forums, so I had to break up my message quite a bit, I’ve attached system logs and the results. is frozen, similar to the issues I ran into with nvidia-smi. I failed to mention that nvidia-smi and all other commands like it freeze, I am unable to kill the process or cancel or ctrl+c out of it. The only method to correct it is to reboot the machine.

kern.log (107.0 KB)

nvidia-bug-report.log.gz (3.7 KB)

syslog (183.3 KB)

dmesg.log (82.1 KB)

Thank you for any help!

RmInitAdapter failed! (0x26:0x56:1429)
The nvidia driver doesn’t like your board, known driver bug. Known working driver versions are <=460, 470.54-470.82. You might also try the open source modules of the 515 driver.

1 Like

470.82 did the trick, thank you generix!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.