Multi GPU setup rendering

Good news everybody!
I found a render farm supporting Omniverse:

And very fast, friendly and pro support.

I tried a setup like this:

My test render is quite nice, Path traced with 256 samples:

But the usage of this powerful 6 x RTX 3090 setup was very modest:


See, only one of the six GPU´s is in real use - well 13 %. The rest are only 1 or 2 %.

My rendering settings are:

The SLI is disabled on their server setup. It must be something else.
Nvidia gurus, please help me on this?

When this is maxed to full rendering potential, it shall be huge! Specially if we get Iray to Machinima :P

1 Like

If you want to use this service, please use this code:
https://bit.ly/pirender

But until the above issue is no resolved, I recommend using just the single card setup: GPU SERVER 3

1 Like

Thanks for reaching out! Nice test scene!

Windows task manager by default doesn’t show the correct device utilization graph. Click on the small arrow next to 3D and select what should be called Graphics_1 I believe.

Kit can also show device utilization. I’m not sure if this is exposed in Machinima, though. In Kit, enable the GPU profiler via Window → Profiler → GPU Profiler. (You can close this window now). Then open Window → Statistics, and select the GPU Utilization scope.

GPU 0 Weight in the PT MGPU settings denotes how much work is assigned to the primary GPU in relation to the other GPUs. The primary GPU typically does some extra tasks such as OptiX denoising and display, that’s why it’s 0.65 by default. If your device utilization shows that GPU 0 is underutilized, you can increase this value. Likewise, if it’s at 100% while the other GPUs are underutilized, you can lower it a bit, to squeeze out maximum overall performance.

1 Like

Ok, we test this again!

Thanks for giving Omniverse apps a try.
If GPU Profiler is not available in Machinima, I recommend the following tools for accurate multi-GPU utilization instead of task manager:

  • nvidia-smi (In powerShell type “nvidia-smi -l 1”)
  • TechPowerUp GPU-Z utility (sensors tab)

Hi Pekka, Thanks for sharing the helpful information. I’m on the way to find a render farm for my upcoming Omniverse project. Looks like irender’s service will be useful to us. I will try them out. but, have you tested again?

Hi! No sorry I got a work assignment ( make it in Machinima ) and deadline is today :P

Hello! we got multi GPU to work, but we also got some tiny horizontal lines with it to our test renders.

Here is Path Trace samples per pixel :1
No problems in render:

But here the value has been raised to 64. It renders fast but errors appear now:

So how can we track what is the reason for this?

while waiting for your answer, I found this:

To enable Multi-GPU you must launch NVIDIA Omniverse™ Kit adding the following argument to its command line:
--/renderer/multiGpu/enabled=true

To set the maximum number of GPUs used add the following command line option:
--/renderer/multiGpu/maxGpuCount

https://docs.omniverse.nvidia.com/prod_rtx/prod_rtx/manual.html


I guess this not the case with Machinima anymore?

I just tried iRender farm with 4 x RTX 3090

Same error again, horizontal lines in Machinima Path Traced rendering:

I activated “render farm” extension, but if I select Path Traced rendering engine, then the “output” folder options disappear :/

I have to render now with single GPU setup from iRender.
Solution for this is really needed, it renders so fast there… If we could only find out what makes these horizontal lines on renderings…

Can you share above scene with me for internal testing? You can send me a direct message. Thanks!

1 Like

Did that tbiedert

Thanks!

In Render Settings → Path Tracing → Sampling & Caching please experiment with the settings for Enable Caching and Enable Many-Light Sampling.

Try disabling one or the other, or both.

1 Like

It´s working!!!
tbiedert you are the guru

1 Like

sofiada
It´s working!!

1 Like