Multiclass classification on Clara Train SDK

We’re trying to train a 2D image multiclass classification model on Clara Train SDK, our train configuration JSON file is edited from the documentation on this URL Model training and validation configurations — Clara Train SDK v3.1 documentation ( on the Classification model example section.
However, we seem to notice that the configuration in the documentation seems to be multilabel classification, which is not what we wanted, so we tried to change the configuration to support multiclass classification. We also noticed that our current configuration might not be fully converted to multiclass classification due to an error from using the loss “WeightedMulticlassClassificationLoss” and got the error in the below image

We would like some help to diagnose what would we need to change to make our train configuration train a multiclass classification model. The datalist.json file and config_train.json file is embedded below.
datalist.json (198.9 KB) config_train.json (3.9 KB)

I am also curious about this and am experiencing the same error. Did you ever figure it out?

Thanks for your interest in Clara Train SDK. Please note we have recently release clara train V4.1 based on MONAI 0.8 which uses PyTorch.

Which release are you facing this error with ?