Multiple Cuda Issues

  1. Am i correct in thinking that anything compiled with the Cuda 1.0SDK will not support my videocard? I have a commercial physics plugin (.dll) complain when installing the plugin.dll that it could not find cudart.dll!

So I then installed the 1.1 toolkit, and it did not want to work…I then installed the 1.0 toolkit, however this time i got an error message during the 1.0 Toolkit install that “No Supported Videocard was found”. However my plugin will install and work okay then, however it’s showing absolutely no improvement over the non CUDA version.

This makes me think that the 1.0 SDK does not support the 8800GTS (G92), and thus my plugin which claims Geforce8 Compatibility is not actually going to be compatible, and I’ve now spent a lot of money for nothing?

  1. I have tried downloading some examples from Nvidia’s site, Cuda demos like Fluidgl and get the error message: “Graphics interopability on multi GPU systems currently not supported…”

!!! But i don’t have multiple GPUs only a single 512Mb 8800GTS !!!
In fact I’m running an X38 which doesn’t support SLI at all.

  1. Distribution:
    What’s the licence agreement for Windows with Cudart.dll?
    I found this thread that if solved, would of saved me a days worth of effort.
    http://forums.nvidia.com/index.php?showtopic=29640
    Why can’t developers release the version of the cudart.dll that is used to compile?

  2. On the Nvida Developers page i noticed this:

“CUDA 1.1 Released!
The new version of NVIDIA’s GPU computing suite includes several new features:
* CUDA integrated into display driver (169.09 and above on Windows)
* Support for GeForce 8800 GT”

If Cuda is integrated into 1.69.21 or 169.25 than why am i having so many issues and have to install the toolkit? And also regarding getting Cuda working with OGL demos etc, that claim 8 series compatibility?

Any information or light that could be shed, would be appreciated.

Cheers,
Scott.

There really are some compatability issues with different version of CUDA and drivers. Let me explain a little bit.

If your plugin is based on CUDA 1.0 then you need to use 163.x drivers, not 169.x ones. Anyway, 8800GT and 8800GTS/512 are NOT SUPPORTED by CUDA 1.0.

If your plugin is based on CUDA 1.1 then you need 169.x drivers and 8800GT and 8800GTS/512 should be okay. Anyway, I don’t think it’s good idea to install CUDA toolkit, your CUDA-enabled software should contain all required redistributable files.

CUDA is not supported on Windows Vista (you’ve mentioned 169.25 which is AFAIK Vista driver and doesn’t support CUDA).

My suggestion is to contact support team of your physics plugin vendor.

As mentioned that really only accounts for the one problem, Meantime I have the Multiple GPU Error when running Fluidsgl.exe from the Nvidia website, as mentioned i only have a single GPU config. Is this simply because Vista has no support for CUDA at all? And why the incorrect error message?

I’m also looking at developing myself, if i recompile the Nvidia examples with 1.1, am i likely to get it too work? I’m assuming that the Nvidia examples are all 1.0?

I have now installed 1.1 and get a crash with Fluidsgl application error - (0xc000007b).

Click ok terminate the error. (Rather than Multiple GPU error in 1.0) Very disappointing if i cannot develop my own tests on my brand new GPU, that Nvidia claims throughout there website supports CUDA. Are there perhaps some compiled 1.1 demos anywhere i can try? I have not got around to loading my IDE into Vista yet.

Thanks for your suggestion and ideas on the matter, much appreciated.

Well the fact that you are running Vista pretty much means you cannot use CUDA at all at this time until a next release.

The fact that error messages are nonsensical on a non-supported platform are to be expected I guess.

CUDA is NOT supported on Vista. There’s much pressure on NVIDIA about this, so I believe it will be supported soon. 169.25 for Vista doesn’t even contain nvcuda.dll which is reqired for CUDA operation (and which is present in 169.xx for XP).

If you’re going to develop some software my suggestion is to use Windows XP (or Linux). And you should definitely use CUDA 1.1 (and uninstall 1.0 completely) — examples and everything should work OK under XP and CUDA 1.1 on your 8800GTS/512 board.

As for your plugin — yes, the only way to get it work is to recompile it with CUDA 1.1.