Multiple MCX455A-ECA showing GUID of 0x123

I picked up a couple ConnectX4 single-port HCAs second-hand that are showing an invalid GUID. They all are showing 0123 for GUID and hardware version of 0. I’ve updated the firmware and OFED to the latest. I’m not sure what to do next. Are these cards faulty? Any ideas?

hca_id: mlx5_0

transport: InfiniBand (0)

fw_ver: 12.16.0152

node_guid: 0000:0000:0000:0123

sys_image_guid: 0000:0000:0000:0123

vendor_id: 0x02c9

vendor_part_id: 4115

hw_ver: 0x0

board_id: MT_2180110032

phys_port_cnt: 1

Device ports:

port: 1

state: PORT_DOWN (1)

max_mtu: 4096 (5)

active_mtu: 4096 (5)

sm_lid: 0

port_lid: 65535

port_lmc: 0x00

link_layer: InfiniBand

Querying Mellanox devices firmware …

Device #1:


Device Type: ConnectX4

Part Number: MCX455A-ECA_Ax

Description: ConnectX-4 VPI adapter card; EDR IB (100Gb/s) and 100GbE; single-port QSFP28; PCIe3.0 x16; ROHS R6

PSID: MT_2180110032

PCI Device Name: /dev/mst/mt4115_pciconf0

Base GUID: 0000000000000123

Versions: Current Available

FW 12.22.1002 N/A

FW (Running) 12.16.0152 N/A

PXE 3.5.0403 N/A

UEFI 14.15.0019 N/A

Status: No matching image found

It is possible that someone reflashed HCA’s with wrong GUID’s. However the HCA’s may be fine.

Try this:

Install CentOS/RH7.5 (inbox driver should be fine, at least for testing)

Set the port type to desired value (see MFT user manual, mlxconfig command)

Connect hosts the with the EDR cable and if you are interested in checking IB, start opensm service

Configure interfaces and run ‘ifuip up’

Verify port state with ibv_devinfo