MX Linux 19.1 doesn't detect HDMI external display on Lenovo ThinkPad P52

Hi everyone!

I’m looking for some help regarding the following issue. I’m attempting to use:

  • MX Linux 19.1 (Patito Feo)
  • an external display
  • in Hybrid mode
  • with secure boot disabled
  • on a Lenovo P52
  • with intel/nvidia
  • over HDMI
  • using the nvidia drivers from nvidia driver installer. Tried these 3 configs:
    - bumblebee-nvidia (none) nvidia-driver (none)
    - bumblebee-nvidia 3.2.1-20 nvidia-driver 418.74-1 (current config)
    - bumblebee-nvidia 3.2.1-20 nvidia-driver 440.82-1~mx19+1

The screen is not detected by the “displays” app.

Reproducible: Always

Steps to Reproduce:
Connect screen over HDMI

Actual Results:

Expected Results:
Screen shows up on the “displays” app to be used

Any help on this matter will be much appreciated! I’ve spent a week on this issue already and I’m overwhelmed by all the information available.

nvidia-bug-report.log (386.3 KB)

My output of intel-virtual-output:

$ intel-virtual-output -f
No VIRTUAL outputs on ":0.0".

$ optirun intel-virtual-output -f
No VIRTUAL outputs on ":0.0".

xrandr output while connected to a HDMI display

$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:modesetting

$ lspci | egrep 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation Device 3e94
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GLM [Quadro P2000 Mobile] (rev ff)

Thanks for your time!

You’re using the Xorg modesetting driver, for intel-virtual-output/bumblebee to work you’ll have to use and configure the Xorg intel driver.
Otherwise, you can uninstall bumblebee and configure PRIME:

1 Like

Hi @generix many thanks for your comment and for the time you took to help me out :)

I ended up moving to Manjaro where I could finally get the external display to work :)

For those in the same situation (optimus laptop intel/nviadia cards). The problem in my setup is caused by the fact the the HDMI port is connected to the nvidia card, not to the intel one. For this reason, the nvidia card needs to be running for the display to be detected. As @generix pointed out, one of the ways to fix this issue is to configure PRIME, meaning, ‘disable’ your intel card and work with nvidia exclusively; in this way the external monitor can be detected.

Doing so in Manjaro is pretty straight forward after lot of research:

On a fresh install (using non-free drivers), install optimus-switch for your desktop environment: This will setup your system to use intel/nvidia PRIME. At any point you can switch to intel-only card by running a shell script and re-booting. I haven’t notice my fan to be used more often after this change.

Hope this help someone!