MX350 on Acer Swift 5 not working, XID 79


Sorry for double posting on the other forum here (, but I just found out those are not the same forum and I should have better posted here.

Recently my company bought me an Acer SF514-54GT with MX350 and i7-1065G7. In Windows, everything works fine, but not in Ubuntu 20.04.

After logging in, the desktop will freeze in about 10 secs, and CTRL+ALT+Fn won’t switch it to consoles. I had to use REISUB or SSH from another computer to gain access and power the computer down gracefully.

This only happens in Nvidia mode in PRIME settings, and in on-demand mode, it will not freeze, but the control panel shows GPU losing connection in about the same 10 secs after logging in as I can see temperature ans memory usage drop to zero.

Driver I tried is the 440 version supplied by Ubuntu, I also tried manually upgrading the kernel to 5.6 and 5.8 and using NVidia’s official driver package, and the problem remains the same.

If I switch to the console before logging in, I can see kernel error message GPU has fallen off the bus, and I tried those common XID79 remedies like pcie_aspm=0 and acpi_osi=Linux, Windows 2009 and a few others, as well as the rcu trick. Nothing worked. Running nvidia-smi -pm 1 before XID79 occurs won’t prevent it from happening either.

Also tried a few conf files to set the GPU to minimal power mode, with no help. Tried to add my computer’s DMI name to optimus trick file, with no help. Tried to set modeset=1 and 0 in nvidia-kmod.conf, with no help.

Laptop BIOS is the latest 1.14, VBIOS unknown, all upgradeable devices are upgraded using fwupdmgr, and I genuinely don’t know what to do next.

Attached is the file generated by, please take a look and let me know how can I get it to work.

report.gz (145.7 KB)