My cuda toolkit was a error version,how can to repair this?

When I used ROS recently, I was prompted to TF2_ The so Library of ROS is missing, so I try to reinstall it, but it seems to remind me that my current CUDA toolkit version number is incorrect. How can I correct this error

Hi,

Based on the log, python-tf2-ros requires CUDA v10.2.460.
However, it can not be installed since the BSP only supports v10.2.89.

Is it possible to upgrade your environment to r32.7.1 and try it again?

Thanks.

i was use ota update ,but it is not find ,i need changed it was what?

Maybe I have a problem with the OTA upgrade process? But it seems that I can’t upgrade through OTA normally

Hi,

Based on the below document, please use r32.7 instead.

deb https://repo.download.nvidia.com/jetson/common r32.7 main
deb https://repo.download.nvidia.com/jetson/t194 r32.7 main

https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3271/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/updating_jetson_and_host.html#


Change the repository name and download URL in the deb commands.

The original commands are:

deb https://repo.download.nvidia.com/jetson/common <release> main
deb https://repo.download.nvidia.com/jetson/<platform> <release> main

Where:

  • < release> is the release number of the minor release you want to update to. For example, to update to minor release 32.2, replace r32 with r32.2. OTA updates to the latest point release of the specified minor release (release 32.2.1 in this case).

Thanks.

It seems that it doesn’t work properly. My Jetson model is Jetson nano. What should I do to modify it

It seems that 194 is not a Jetson nano. I still report an error after upgrading it to 210

Hi,

t210 is the correct platform for Nano.
Have you run the sudo apt update after modifying the file?

Thanks.

When sudo apt upgrade is used, as in the third article in the tutorial, it still seems to report an error

Hi,

Is SDK Manager an option for you?
If yes, would you mind reflashing the system with SDK Manager directly?

Thanks.