My jetson nano is not showing any hdmi output

it was working find but suddenly everything went black on screen
also jetson nano developer kit not giving output to any if its usb peripherals but green light is on

If changing to other HDMI cable or power cable can’t work, can you try to reflash you device with JetPack via SDK manager again?

Follow the guidance. Put your board into recovery mode and flash it.

No response form jetson,
We have tried recovery , flashing and everything we could still the same as only green light is ON ,no hdmi OUTPUT

You mentioned recovery being tried. Do you know if recovery mode at least exists where in recovery mode the Jetson is detected on the host PC with lsusb or perhaps with sdkmanager seeing the unit? If not, then that would probably be a hardware issue. Knowing if there is serial console activity would also be a big help.

there might be a hardware issue same as mine

what we gonna do about that hardware now we brought this 10 days ago from your official vendor

So is the flash process can be done or nor?

No it is not done but we have tried from our side

Could you at least share some log so that we can tell what is going on there?

1 Like

this process we tried to follow but we couldn’t find proper guide for installation (flashing) jetson.
Is there any proper guide that you share us ?

You would install sdkmanager on an Ubuntu 18.04 host PC. The Nano or other Jetson would be connected to the host PC via the correct USB connector (micro-B cable on the Nano), temporarily short the Nano recovery pin to ground (there is a ground pin right next to the recovery pin), power up the Nano, remove the shorted pin, and on the host PC run:
sdkmanager

More details available if you need, but know that SDKM does have an “export log” button if you have a failed flash and need to post logs. JetPack/SDKM is available here:
https://developer.nvidia.com/embedded/jetpack
(use the most recent JetPack 4.x series, don’t use the JetPack 5.x series on a Nano)

1 Like

we are working on it
Just curious what if we change jetson nano module with another one does it will make any difference

If two different module types can work on the same carrier board, then very likely they can flash without issue, but might need different device trees. When you run the official flash software for the dev kits, then the switching of correct device tree is often automatic simply by naming the target. This might not always work though since part of the tree is for the module, and the other part of the tree is for the carrier board; if the flash software had no knowledge of that combination it is conceivable you would have to set up device tree manually. For the most part though, if this is a dev kit carrier board, then it is worth simply flashing to see if it works (many will work).