My PC does not even recognize the existence of a GPU

We just bought lots of laptops for develeopment in my company and installed Ubuntu 18.04 first due to our dependincies. However lspci showed existence of a Nvidia device, but never recognized which model. Over the week we read all the all the possible solutions that Generix gave, installed almost all the drivers from 440 to 495 yet we only had black screen. We purged the entiere system and made a clean Ubuntu 20.04 install. Now it does not even recognize existence of any nvidia device.

  • No output from ubuntu-devices drivers
  • No nvidia device from lspci
  • Secure boot disabled

Some machines run on Windows and we can see the RTX 3060 over there. We are in great pain and agony, if someone can help greatly appricieated
nvidia-bug-report.log.gz (391.7 KB)

To get a proper display name, just update the pci-id database:
sudo update-pciids

The problem is that the kernel 5.4 that comes with 18.04 is too old to support your intel igpu which is driving the internal screen. The nvidia gpu is up and fine.
If you really need to use 18.04, you’ll have to upgrade the kernel, e.g. by adding the liquorix ppa:

Furthermore, please don’t use the runfile installer of the nvidia driver, run it with --uninstall option to uninstall and then just select the driver from Ubuntu’s Software&Updates application.

It didn’t worked in Ubuntu 20.04 as well, as I mentioned. So I made a fresh Ubuntu 21 installation. I always do update pciids and I updated them again as well in this fresh install. Still no nvidia output from lspci.
I tried to install drivers with Ubuntu Software &Updates from additional drivers section but since it did not detect any dGPU there was nothing to install.
So I proceeded to install with .run file just to make sure everything is fine. However, driver was not able to initialize. nvidia-smi gives communication error. Many many thanks.

Here is my bug report:

nvidia-bug-report.log.gz (88.2 KB)

According to the serial numbers, the logs are from two different devices. The one running 21.10 is not only missing the nvidia gpu but the whole pci bridge 0000:00:01.0 it’s connected to. Please check if it’s disabled in bios.

Yes , as I mentioned we bought 6 of the exactly same computers. To not stop the work we upgrade machines whenever any of them is not needed. However symptoms are exactly the same for al of them. I will check from bios and let you know. Thank you.

Hi we checked the bios and there was not any bios setting for pci bridge. Is there any recommended bios version for MSI Katana?

I guess the setting are only available in the hidden expert settings. Please just try loading defaults in the bios, then check your manual on how to use the “battery reset hole” to reset the mainboard.