My steam flow is not running when imported to other empty scene

Hi, see the video please:

What can we do with this?

Thanks for the video, @pekka.varis! I’m having the dev team take a look at this. It might be helpful to if you could share your usd file with us. You can attach it here or email it to me at:

This is due to RTX settings not carrying across a USD reference/payload. Need to enable RTX Settings->Common->Flow. Additional settings should be configure like ‘Flow in Path Trace’ and ‘Flow in Translucency’.
One trick to do this is just to create a Flow preset in your main stage, and then delete the prims created. Adding the preset automatically configures the RTX settings.

1 Like

Thanks @areidmeyer
If you watch again the video I posted to beginning of this topic, you see that I do all the tricks you mentioned…

There is something else in here bugging…

1 Like

Watched video, yes that is strange. Are you able to share the stage? That might help me sort out what happened.

Thanks! here you have it @areidmeyer

Steam.usd (15.5 KB)

I just toggled visibility on the Environment xform, and there the Flow was, under the floor. But working otherwise.

COOL, please can you share a video how you do it?
I just cannot make it, see here:

This time I went ahead and installed Create 2022.3.0, just to see if that made the difference.

Turns out it does make a difference. Flow itself isn’t busted, the animation is what breaks. So if you set the flowEmitterSphere radius explicitly, Flow goes active again.

Whatever the bug is, it appears Create 2022.3.1 fixes it.

1 Like

good to hear this! I try when it comes out :)