My UART runs with some error

I am trying to connect my PC and Jetson Nano using UART. But I come across a problem that the data transmitted to PC are always garbled code. What I’ve tried is to plug in J41 6,8,10 with USB to TTL cable. My problem is when I transmit data to NANO, it works normally. But it can’t work from another side, the data transmitting to PC are always encoded incorrectly without any regulation. I try to find out the problem from the process of encoding, but I still get nowhere.
Being a beginner in the field of programming and Linux. I would appreciate it if any of you could give me recommendations.

How about the result of Jetson Nano J44 Pin 2/3/6?

https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

I tried J44 Pin when first faced with the problem, but I fail to find its absolute path to open. I mean when I am using J41 I can find it at (/dev/ttyTHS1), but I don’t know the absolute path for J44? Could you give me some information about them, thanks a lot.

Hi 086177,

When using J44, you could send/receive data from your PC using console tools on /dev/ttyUSB0.

This path is on the host but not tegra side.

If I am not mistaken, the tutorial you offered is connecting PC with Ubuntu to NANO. There is a little difference between us. The operating system my PC is using is Windows 10. What I am doing is attempting XCOM 2.0 on my PC, which is a terminal application. And I have trouble solving the decoding problem. Thanks for your patience.

In the case of garbled content you might have the speed correct, but bits or stop bits or parity mismatched.