Nano developer kit fails to boot

Hi, I have two nano developer kits, inserting the same tf card, soc1 fails to boot, hanging at “Starting CPU & Halting co-processor”, while the other one: soc2 successfully enter the ubuntu system. Below are the messages from serial console, two messages are almost the same except that soc1 stucks in ”Starting CPU & Halting co-processor“ while soc2 moves on. Could anyone give me a hint about which part of the soc1 hardware goes wrong? Thanks in advance.
soc1 :
nanoDevSoc1.txt (4.2 KB)
soc2:
nanoDevSoc2.txt (20.3 KB)

Hi,

Please try to use sdkmanager to flash both of your device + sdcard and see if the issue is still.

Sorry for the late reply and thank you for your advice.
I have tried to use sdkmanager to flash nano developer kit, it hangs at the flashing step, the log is:
NV_L4T_FLASH_NANO_DEVKIT_WITH_OS_IMAGE_COMP_fail.log (12.2 KB)

while messages from serial console is:

[0127.723] Enabled early print
[0127.725] [L4T TegraBoot] (version 00.00.2018.01-l4t-1463e5a5)
[0127.731] Processing in recovery mode
[0127.734] A02 Bootrom Patch rev = 1023
[0127.738] Power-up reason: pmc por
[0127.741] Established communication link with host
[0128.952] NvTbootI2cWrite(): error code 0x00045100 Error while starting write n
[0128.960] NvTbootI2cDeviceRead(): error code 0x00045001 Error while sending the
[0128.969] NvTbootI2c: Read failed for slave 0xac, offset 0x00 with error code 1
[0153.134] Odmdata from BCT: 0x00094000
[0153.138] DebugPort= 0x3
[0153.147] BoardId read from EEPROM/NCT: 3448
[0153.151] BoardID = 3448, SKU = 0x0
[0153.178] NvTbootInit_Porg: Setting GPIO_A6 for HDMI …
[0153.183] max77620 setting MBLPD bit
[0153.187] No Battery Present
[0153.190] RamCode = 0
[0153.192] Platform has DDR4 type RAM
[0153.195] max77620 disabling SD1 Remote Sense
[0153.200] Setting DDR voltage to 1125mv
[0153.204] Serial Number of Pmic Max77663: 0x1334e9
[0153.211] Entering ramdump check
[0153.214] Get RamDumpCarveOut = 0x0
[0153.218] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0153.223] Last reboot was clean, booting normally!
[0153.227] Sdram initialization is successful
[0153.232] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0153.238] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0153.244] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0153.250] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0153.255] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0153.261] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0153.267] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0153.273] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0153.289] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0153.295] Platform-DebugCarveout: 0
[0153.299] Downloaded BCT successfully
[0153.683] Downloaded Bootloader successfully
[0153.733] Downloaded rp1 successfully
[0153.975] MAX77620_GPIO5 configured
[0153.978] CPU power rail is up
[0153.981] CPU clock enabled
[0153.985] Performing RAM repair
[0153.988] Updating A64 Warmreset Address to 0x92c002e9
[0153.994] Enable APE clock/reset
[0153.997] Error in NvTbootGetTOSBinaryLength: 0x11 !
[0154.002] Loading Secure OS image failed.
[0154.006] Set NvDecSticky Bits
[0154.009] GSC2 address ff53fffc value c0edbbcc
[0154.016] GSC MC Settings done
[0154.020] Next binary entry address: 0x92c00258
[0154.024] BoardId: 3448
[0154.027] Overriding pmu board id with proc board id
[0154.032] Display board id is not available
[0154.036] Starting CPU & Halting co-processor

the process is stuck where the same message “Starting CPU & Halting co-processor” appears , any idea what is the problem with the soc?

I run into another problem which is I cannot login to the sdkmanager “developer.nvidia.com”. It says invalid email or password. I am sure they are both correct because they can be used to login to this forum, and I can login to sdkmanager a few days ago. My email account is lovegreenf@aliyun.com, could anyone help me with this? Thank you so much.

Hi lovegreenf,

Could you switch the modules and carrier boards to make sure this happens to specific module but not related to carrier board?

If only one module can hit such issue, please RMA this one.

Dear WayneWWW,

Thank you, only one module has this problem, I will return it.
Could you help me solve the sdkmanager login problem?
I upload the skdm-log if it helps.
sdkm-2020-09-17-13-17-01.log (11.5 KB)

In the log, there is devzone signIn error. I paste the devzone link to the browser to try to login. The browser displays:

The engineer from sdkmanager team will handle this.

I’ve unlocked your account, but the message in the screenshot usually indicates that cookies have gotten damaged somehow. Can you please try again? If you get the same message, try in a different browser or an incognito window.

Thanks!

Fred

I can login to my sdkmanager account now, thank you soooooooo much

Great! Thanks for letting me know.

sorry for disturbing you again, I have another sdkmanager login problem.

Hi @lovegreenf,

The team is looking into this issue.
Thanks for your patience.

Tom

Hi @lovegreenf,

Based on the image you attached, it appears that you clicked the back button and then was trying to login again.
This is known issue since each step in authorization flow can be presented only once.
Can you please try logging in again?

Thanks,
Tom