Nano software download broken

This file doesn’t seem to extract for me, with 7zip on windows or with tar xjvf on Linux:

Is this corrupt on the server?

Hi John, just tested this in Linux - was able to successfully extract it using tar xjvf after downloading it.

It would also appear that we are from the same region, so not sure what is happening.

Thanks Dusty! Could you send me the MD5 or SHA sum to expect for this file? I get:

  • MD5: 15fda16d83e9a189ea5534108f57af2f
  • SHA256: e4902a952245217227486322b3e8cef47942f87f2ea91f9e67d700314ae3ade3

Hmm, my checksums of this file match these. BTW my tar --version shows version 1.28

Mine shows version 1.29. What’s your bunzip2 and lbzip2 version? I’ve got bunzip2 version 1.0.6, and lbzip2 2.5-2.

Some console output:

$ bunzip2 Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2

bunzip2: Data integrity error when decompressing.
        Input file = Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2, output file = Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tar

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

bunzip2: Deleting output file Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tar, if it exists.
$ bunzip2 -tvv Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2
    [1: huff+mtf rt+rld]
    [2: huff+mtf rt+rld]
    [3: huff+mtf rt+rld]
    [4: huff+mtf rt+rld]
    [5: huff+mtf rt+rld]
    [6: huff+mtf rt+rld]
    [7: huff+mtf rt+rld]
    [8: huff+mtf rt+rld]
    [9: huff+mtf data integrity (CRC) error in data

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

$ bunzip2 --version
bzip2, a block-sorting file compressor.  Version 1.0.6, 6-Sept-2010.

   Copyright (C) 1996-2010 by Julian Seward.

   This program is free software; you can redistribute it and/or modify
   it under the terms set out in the LICENSE file, which is included
   in the bzip2-1.0.6 source distribution.

   This program is distributed in the hope that it will be useful,
   but WITHOUT ANY WARRANTY; without even the implied warranty of
   LICENSE file for more details.

$ sudo apt install lbzip2
Reading package lists... Done
Building dependency tree
Reading state information... Done
lbzip2 is already the newest version (2.5-2).

Dusty, thanks for taking the time to help me! A coworker was able to extract the zip file to a tar file for me, so my issue is solved. No idea why, as his version of bunzip2 was the same as mine. So my problem is solved, and was on my end, though I’m not sure what was wrong.

Thank you!

I downloaded and it extracted fine with the same version of bunzip2 as you on Ubuntu 18. How reliable is the storage medium you are using? Have you tried re-downloading to and extracting from a different one?


I’m facing the same issue. I am not able to extract the package with tar nor 7zip. I checked on two different computers.

There must be something wrong with the archive - it is much smaller after extracting.

Could you please try to reupload the file?

Thank you and best regards,
Jan Moravec

Hi Jan, we are refreshing the file on the server, please try back in a bit.

Is this the problem with Ubuntu’s recent bzip2 update? We had similar problems with Xavier and SDK Manager:

Yes, it was this bzip2 problem. I’ve solved it by building current bzip2 from source code.

But still, when using other archive managers than bzip2 or tar, or when compiling with Yocto, there is the issue again.

Thank you,
Jan Moravec