"Need Assistance with Jetson Orin Boot Issue During Flashing Process"

request assistance with a boot issue that I encountered on my Jetson Orin development kit. I attempted to re-flash the device using the SDK Manager tool on a connected host laptop running Ubuntu 18.04. However, during the flashing process, I encountered an error that prevented me from completing the process.

Specifically, when the flashing process reached around 30%, a pop-up window appeared, prompting me to select the manual installation option. I selected the correct Jetson Orin AGX developer kit (32GB) and entered my username and password. I then clicked on “Continue” to proceed with the installation process. However, after a further 5% of progress, I received an error message that prevented me from completing the process.

I have attempted to re-flash another Jetson Orin development kit without encountering any issues. As such, I believe that the problem is specific to the device that I am experiencing issues with.

Hi gmptp,

Is that the AGX Orin devkit from NVIDIA?

Are you using the standalone Ubuntu 18.04 or 20.04 as your host PC?

It seems only one device having the flash issue with SDKM.
Have you tried to flash with flash command?

Could you also help to provide the flash log from host side for further check?

  • Is that the AGX Orin devkit from NVIDIA?

Yes, the AGX Orin DevKit 32g from NVIDIA.

The standalone laptop (host) I’m using to flash the Orin is running Ubuntu 18.04.

For this project we have 12 Jetson Orin AGX DevKits. I’ve had no issues flashing the others. This Jetson was working and gave a kernel panic and now I’m getting a disconnect type error during the flash process using the SDK manager Gui. Can you give me step by step direction to use the flash command so i can confirm I’ve tried it?

Thank you,

You should put the board into recovery mode. It is not about any flash command.

It is about pressing the button on the carrier board. Didn’t you use it while flashing your other orin devkits?

Yes, I had no issues flashing the other jetsons. I’ve refreshed them a few times too. Understood the recovery mode requirement.

What is the current situation? You are sure the board is in RCM but sdkmanager cannot detect it?

It’s getting to about 30%. The pop-up window comes up. I select manual and create a UN PW hit the next 10% moves, and then it says it cannot, in so many words, detect jetson. I tried different cables and even tried flashing another jetson, and no issues. Pulled the error log off the terminal of the standalone laptop used to flash the jetson and waited for a response from the group.

Please share both host side log and device side log.

Device side log requires to use the micro usb port to dump.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.