Need Help Nvidia Tesla m2050 setup on Linux/Ubuntu, SOS!!

Hi, I must be stupid! I’ve probably installed Ubuntu 30 times or more and the last 4 days, and I’m getting sick of it. I’ve been trying to setup my Tesla m2050 on Ubuntu 16.04 LTS 64Bit for GPU computing. And the GPU I want to use for the displays is a Intel HD 4400.

Tried to install from nvidia-375.20 driver file:
step 1: Disable nouveau driver

sudo apt-get install dkms build-essential linux-headers-generic
sudo nano /etc/modprobe.d/blacklist-nouveau.con

added these lines:

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off
echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
sudo update-initramfs -u

step 2: Now reboot, and enter tty ( Ctrl+Alt+F1 )

sudo service lightdm stop
sudo chmod 777 ./
sudo ./

I did get this when installing.

Unable to find a suitable destination to install 32-bit compatibility libraries. Your system may not be set up for 32-bit
compatibility. 32-bit compatibility files will not be installed; if you wish to install them, re-run the installation and set
a valid directory with the --compat32-libdir option.

sudo reboot

When the system has started I go to login and the screen flashes and goes back to the login screen. I google nvidia login loop ubuntu but found no help.

And when I try to install the nvidia-375 drivers from the PPA, and reboot the system it starts in low graphics mode. Google was no help. LOL. Have any ideas, thinks. :-)

I also tried this with nvidia 352.55 but it does the same thing.