Need help on installing Mellanox OFED on RHEL 6.4

Hi all,

Recently I downloaded the Mellanox OFED [ MLNX_OFED_LINUX-2.2-1.0.1-rhel6.4-x86_64.tgz ] and tried to install using mlnxofedinstall script on my rhel system with kernel 2.6.32-358.46.2.el6.x86_64. The installation was succesful and firmware was upto date. After restarting /etc/init.d/openibd I ran hca_self_test.ofed which resulted in the following output.

---- Performing Adapter Device Self Test ----

Number of CAs Detected … 1

PCI Device Check … PASS

/usr/bin/hca_self_test.ofed: line 165: [: too many arguments

Host Driver RPM Check … FAIL

REASON: no RPMs found for currently booted kernel 2.6.32-358.46.2.el6.x86_64

Kernel Arch … x86_64

Host Driver Version … NA

Firmware Check on CA #0 (VPI) … NA

Host Driver Initialization … NA

Number of CA Ports Active … NA

Error Counter Check … NA

Kernel Syslog Check … NA

Node GUID on CA #0 (VPI) … f4:52:14:03:00:2a:bd:70

------------------ DONE ---------------------

The result was same after rebooting the system. On running sestatus

SELinux status: enabled

SELinuxfs mount: /selinux

Current mode: permissive

Mode from config file: permissive

Policy version: 24

Policy from config file: targeted

And ifconfig didn’t show up the ib interface. Is there anything that I have missed to configure before/after installation of Mellanox OFED?

Hi Erez,

Thanks for your valuable response. “ibv_devinfo” correctly displayed the hardware details. And “ibstat” shows that the link is up and active. I will let you know if I come across issues regarding OFED functioning in future.


Anoop C S.


This is a known issue with the driver and kernel version you’re using and is supposed to be fixed in the next driver release.

Regardless, you shouldn’t be putting your faith on this script in order to verify you have the correct configuration in place.

I suggest using “ibstat” or “ibv_devinfo” in order to verify physical connectivity. let me know if you need further help on this.