Need help with akmod-nvidia installation


I’ve been trying to get my nvidia drivers working, but wasn’t successful so far.
The target system is a Dell XPS with a GTX 1050. I followed the tutorial here at rpmfusion(.)org/Howto/NVIDIA
These are the commands and outputs for determining my card model:

/sbin/lspci | grep -e VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
/sbin/lspci | grep -e 3D
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

I could not find any information that explicitly says my card is supported by the current nvidia drivers, but I assume it is, because as I understand this is a pascal card, and other pascal cards and also the predecessor maxwell generation cards seem to be supported.
I read the additional information on optimus on the separate HowTo page for that where I could find a lot of additional optional configurations I can do, but non that are mandatory to progress with the installation.
So I made sure that secure boot is disabled (which it was already), checked that my system is up to date (which it is), and then executed the installation command.

sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

After that, I waited 5min and used the command from the guide to check if the module was installed successfully.

modinfo -F version nvidia
modinfo: ERROR: Module nvidia not found.

Retried it after 10min, 15min, 30min, 1h, but still the same error.

I also retried this whole process a couple of times now. Always removing the packages with

sudo dnf autoremove nvidia*

and then rebooting, before starting again. I tried with and without cuda, but I had no success.

Please help me with this. I had my GPU working previously on Ubuntu and Arch on the same machine, so I know there should be a way to get this working again on Fedora, too.

I also attached a bug report here.
nvidia-bug-report.log.gz (66.2 KB)