Need help with the Grinch kernel for lxc / docker things

I grabbed the 19.3 kernel source as suggested, and patched against it.

I grabbed my /proc/config.gz and output to .config, ran make and continue to get errors when trying to compile the kernel. Something is weird about my system.

Is it possible someone with a working 19.3 grinch kernel with sources could enable the following and attempt to compile on their host?

root@tegra-02:/mnt/mmcblk1p1/usr/src/kernel# lxc-checkconfig .
--- Namespaces ---
Namespaces: required
Utsname namespace: missing
Ipc namespace: required
Pid namespace: required
User namespace: missing
Network namespace: missing
Multiple /dev/pts instances: missing

--- Control groups ---
Cgroup: enabled
Cgroup clone_children flag: enabled
Cgroup device: missing
Cgroup sched: enabled
Cgroup cpu account: enabled
Cgroup memory controller: missing
Cgroup cpuset: missing

--- Misc ---
Veth pair device: missing
Macvlan: missing
Vlan: missing
File capabilities: enabled

Note : Before booting a new kernel, you can check its configuration
usage : CONFIG=/path/to/config /usr/bin/lxc-checkconfig

I’m cross compiling on my Linux desktop and I was able to compile the kernel with the above settings. I haven’t tried even the self-compiled Grinch kernel yet but I assume it works if Santyago has not forgot to publish any patches.

Looks like the User Namespaces feature got introduced in 3.12 kernel and it’s not in the 3.10 on the Jetson.

Hi sigkill - try new Grinch Kernel 19.3.7. I run lxc-checkconfig, and I have all test passed :)