Need some help debugging PinMux issue Jetson Nano

Recently we found that we were copying our PinMux files we generate over the wrong dtsi files (0000 instead of 0002).
When we copied the dtsi files over the correct files we can’t access the Jetson Module (on our custom board) through SSH and our I2C communication doesn’t work to our microcontroller either.

Because the PinMux is almost completely different now I am not sure where to start looking for the issue. I assume that since the kernel still boots its something small we are missing or breaking. I am attaching the UART log. If someone with more experience with PinMux debugging can help it would be great. I could attach the .dtsi files if that is helpful, but since we have a custom carrier board it might not be helpful.

uart_log.txt (23.3 KB)

I should mention that with the default PinMux dtsi files the kernel boots, we can SSH into it and our I2C communication all works. Also some of our device trees also work.

Sorry for the late response, is this still an issue to support? Thanks

Hi, we figured it out. Somehow some of the default values were changed on the hidden rows of the PinMux excel sheet. Once we reverted them to the defaults it worked again. Still not sure where the changes came from, but it seemed to be our error. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.