NEO installer fails on python-django [CentOS Linux release 7.6.1810 (Core)]

The NEO installer (neo-2.3.1-2.el7) fails on Monitor Provider install due to python-django (see error below). I’ve tried manually installing the NEO-included python-django, but I believe yum won’t accept it because a later version makes it obsolete. I’ve tried every hack I can think of to make it work and have not found a work-around. Any advice?

—> Package python-django.noarch 0:1.4.1-1 will be obsoleted

→ Processing Dependency: python-django = 1.4.1 for package: neo-provider-monitor-2.3.1-2.el7.noarch

→ Finished Dependency Resolution

Error: Package: neo-provider-monitor-2.3.1-2.el7.noarch (neo)

Requires: python-django = 1.4.1

Removing: python-django-1.4.1-1.noarch (installed)

python-django = 1.4.1-1

Obsoleted By: python2-django16-1.6.11.7-5.el7.noarch (epel)

python-django = 1.6.11.7-5.el7

Available: python2-django-1.11.20-1.el7.noarch (epel)

python-django = 1.11.20-1.el7

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

Hi Joseph,

Please try the following to workaround this issue:

  • Uninstall NEO => /opt/neo/neo-uninstaller.sh
  • Remove the current python-django package => yum remove python-django
  • Untar NEO installation into a folder called neo => tar -xvf neo-2.3.1-2.el7.tar.gz
  • Manually Install python-django-1.4.1-1 package - included in NEO installation]=>
    • yum install neo/packages/python-django-1.4.1-1.noarch.rpm
  • re-install NEO => neo/neo-installer.sh -r

Thanks,

Samer

This is equivalent to workarounds that I’ve already attempted and results in the same error.

A colleague suggested trying to versionlock python django to 1.4.1-1, but that also results in the same error.

Error: Package: neo-provider-monitor-2.3.1-2.el7.noarch (neo)

Requires: python-django = 1.4.1

Removing: python-django-1.4.1-1.noarch (installed)

python-django = cError: Package: neo-provider-monitor-2.3.1-2.el7.noarch (neo)

Requires: python-django = 1.4.1

Removing: python-django-1.4.1-1.noarch (installed)

python-django = 1.4.1-1

Obsoleted By: python2-django16-1.6.11.7-5.el7.noarch (epel)

python-django = 1.6.11.7-5.el7

Available: python2-django-1.11.20-1.el7.noarch (epel)

python-django = 1.11.20-1.el7

Obsoleted By: python2-django16-1.6.11.7-5.el7.noarch (epel)

python-django = 1.6.11.7-5.el7

Available: python2-django-1.11.20-1.el7.noarch (epel)

python-django = 1.11.20-1.el7

The suggested workaround did not work.

I was able to get the installer to succeed by installing many rpm’s manually with localinstall while disabling the epel repo on the command line. I then hacked the installer script pretty severely until it worked. This was pretty horrifying.

In the end, I believe I could have just disabled the epel repo globally and things would have gone much more smoothly.

My feedback would be that this package installation approach of building a script to manage yum is really fragile when you have all of these hard dependencies on versions.

Hi Joseph,

Thank you for the feedback.

Usually from our experience the NEO installation goes smoothly if you follow the prerequisites from the release notes :

https://mellanox.my.salesforce.com/sfc/p/500000007heg/a/1T000000g6eQ/7mNizenIYLDsYf4RUY7rtNTmYxS6gYoZx73RGuMhxfE

The root cause of the issue is related to unsupported OS by NEO .

RedHat/CentOS 7.6 is not supported by the latest version of NEO 2.3.1, this is why you encountered with dependency issues .

We will add official support on the next NEO 2.4 version.

Thanks,

Samer

Thanks – yes, downgrading to Centos 7.4 resulted in a working NEO installation.