Network autoconfiguration failed on headless boot with PuTTY on Nano 2 GB

Having issue configuring the network on setup on headless mode.

I’m using an RJ45 ethernet cable to connect with my laptop which is over WiFi.

When I’m prompted to choose a network interface I chose eth0

Then it is showing me this issue:

puttyprob2

What should I do now?

Can you connect the RJ45 to the same router/WiFi appliance that the host PC computer is using? One has to have a router function in order to get automatically served IP addresses (via the DHCP protocol). It sounds like the ethernet wire is going direct to the laptop without an intervening router.

The micro-B USB can do this same job and will itself pretend to be a router as well as ethernet, but that’s possible because of software running on the micro-B USB port. I do personally prefer the wired gigabit, but without a router you’d have to either:

  • Install router software on your Windows machine so it can use DHCP to assign addresses, or
  • Assign a static IP address to both ethernet ports of the Jetson and PC within the same subnet (not too hard on the Jetson running Linux, not sure about Windows though…there’d be a bit of research for that).

Thank you for looking into my problem and giving me a very clear idea to solve the issue.

Can you name any routing software which I can install on my windows machine?

It would be a great help.

I don’t know what software might be used in the Windows world to let Windows act as a router. Network sharing is fairly simple, but address assignment via DHCP would require something added on, and I’ve never used this with Windows. Someone else may have a recommendation on this, but assuming Windows 10, if I were starting from scratch I might use this search:
Google Windows 10 dhcp server

Hopefully someone else can recommend a DHCP server. However, you still have the option to assign a static IP address on the Jetson. Having a DHCP server directly on the Windows machine would be more flexible, but static assignment does work. In the case of using static address setup on Ubuntu 18.04 there are a number of mechanisms to do this. I personally like using “sudo nm-connection-editor” (you might need to “sudo apt-get install network-manager-gnome”) to set either static or DHCP on a Linux box (you’d use the MAC address of the correct interface to pick eth0…see “ifconfig eth0” for its MAC address).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.