Network Bridge from Windows has bugs

I was using a network bridge via ethernet from windows, it worked, till my windows has been restarted due to updates, and after restarting, I’m not able to connect to bridge from Jetson Nano. I’ve checked my windows settings, and they are alright. I connected another device and it works. But In Jetson Nano’s Network Connections there is a l4tbr0 config that can’t delete and this config is set to manual ip… I set it to automatic, restart nano and there is a new one l4tbr0 with same manual IPv4 settings, and of course- network unreachable… I can delete one when there are two of them, but I can’t delete it when there is only one and network doesn’t connect even if I set it to automatic Ipv4. And v6 is ignored from default… what’s happening with it?? I tried to pullout ethernal, delete bridge connection, restart jetson, but even after that it creates that default bridge with strange settings… I think it looks like as some bug?


First let’s check the power supply. If you are using the usb power supply. The network via the usb cab will not be functional. Pls be aware that.

When you are using a dc power supply. You can use the usb cab just as a network cab. The nano side will work as a dhcp server and dispatch a fix ip to your host side. So that on your windows you will get a fix IP 55.100. Then you can use it to connect you nano board.