Network configuration for Conti ARS430RDI

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
[*] Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.6.0.8170
1.5.1.7815
1.5.0.7774
other

Host Machine Version
native Ubuntu 18.04
other

Hi,
Could you help me setup network of Continental ARS430RDI?
My radar IP address is 192.168.3.32, but i don’t know gateway IP address and netmask.

    sudo ifconfig eth0:900 10.1.0.81 || true
    sudo route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0:900 || true
    sudo route add -net 10.1.0.0 netmask 255.255.0.0 dev eth0:900 || true

How should i setup my network like this example code block?

Dear @aliqz9x5,
Have you tried the same commands and setting up radar IP like 10.1.1.x?

Hi @SivaRamaKrishnaNV ,
I have tried the same commands, it didn’t work for me. I think that commands for ARS430 but I am using ARS430RDI. I think both are different radar sensors.

CONTINENTAL_ARS430
CONTINENTAL_ARS430_RDI
CONTINENTAL_ARS430_RDI_V2
DELPHI_ESR2_5
CUSTOM

It looks like drive works 3.5 have support for ARS430RDI but I am not able to find documentation for routing table.

Dear @aliqz9x5,
Have you tried changing Radar IP as I suggested?

@SivaRamaKrishnaNV
I don’t clearly understand of setting up radar IP like 10.1.1.x.
Do you mean route radar IP address ?

    sudo ifconfig eth0:900 10.1.1.81 || true
    sudo route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0:900 || true
    sudo route add -net 10.1.1.0 netmask 255.255.0.0 dev eth0:900 || true

Do you mean run this code block?
“sudo route add -net 10.1.1.0 netmask 255.255.0.0 dev eth0:900 || true”
route: netmask doesn’t match route address

Dear @aliqz9x5,
I was asking if the Radar IP can be changed to 10.1.1.x and use the same steps to configure eth0:900. Let me know if it does not help. Also, please share the connection details.

Hi @SivaRamaKrishnaNV
I am not able to change IP address of the Radar. Radars comes with 192.168.3.x IP address.

This is my DIY connections, I did it accordingly with the Radar datasheet


Is there any cable for ARS430RDI I can buy?

Dear @aliqz9x5,
The picture is not clear. Could you share the complete connection and the used datasheet reference to confirm the connection


RADAR <—> HSD
1-BR- <—> 4-BR-
2-GND
3-12+
4-NC
5-BR+ <—> 2-BR+
6-NC
7-NC
I am using external 12volt power supply for radar.


Screenshot 2021-07-23 at 11-26-40 Dropbox - Dropbox

Dear @aliqz9x5,
The documentation instrcutions are not generic. We are working on updating them.
Could you check if the below instruction helps?

    sudo ifconfig eth0:900 192.168.3.81 || true
 
    sudo route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0:900 || true
 
    sudo route add -net 192.168.2.0 netmask 255.255.255.0 dev eth0:900 || true