Network configuration for Conti ARS430RDI

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Could you help me setup network of Continental ARS430RDI?
My radar IP address is, but i don’t know gateway IP address and netmask.

    sudo ifconfig eth0:900 || true
    sudo route add -net netmask dev eth0:900 || true
    sudo route add -net netmask dev eth0:900 || true

How should i setup my network like this example code block?

Dear @aliqz9x5,
Have you tried the same commands and setting up radar IP like 10.1.1.x?

Hi @SivaRamaKrishnaNV ,
I have tried the same commands, it didn’t work for me. I think that commands for ARS430 but I am using ARS430RDI. I think both are different radar sensors.


It looks like drive works 3.5 have support for ARS430RDI but I am not able to find documentation for routing table.

Dear @aliqz9x5,
Have you tried changing Radar IP as I suggested?

I don’t clearly understand of setting up radar IP like 10.1.1.x.
Do you mean route radar IP address ?

    sudo ifconfig eth0:900 || true
    sudo route add -net netmask dev eth0:900 || true
    sudo route add -net netmask dev eth0:900 || true

Do you mean run this code block?
“sudo route add -net netmask dev eth0:900 || true”
route: netmask doesn’t match route address

Dear @aliqz9x5,
I was asking if the Radar IP can be changed to 10.1.1.x and use the same steps to configure eth0:900. Let me know if it does not help. Also, please share the connection details.

Hi @SivaRamaKrishnaNV
I am not able to change IP address of the Radar. Radars comes with 192.168.3.x IP address.

This is my DIY connections, I did it accordingly with the Radar datasheet

Is there any cable for ARS430RDI I can buy?

Dear @aliqz9x5,
The picture is not clear. Could you share the complete connection and the used datasheet reference to confirm the connection

1-BR- <—> 4-BR-
5-BR+ <—> 2-BR+
I am using external 12volt power supply for radar.

Screenshot 2021-07-23 at 11-26-40 Dropbox - Dropbox

Dear @aliqz9x5,
The documentation instrcutions are not generic. We are working on updating them.
Could you check if the below instruction helps?

    sudo ifconfig eth0:900 || true
    sudo route add -net netmask dev eth0:900 || true
    sudo route add -net netmask dev eth0:900 || true

Unfortunately this solution didn’t work.

It’s a typo. Please use a correct command as below. Thanks

sudo route add -net netmask dev eth0:900 || true

Hi @VickNV we have tried this as well but it still doesn’t work. Do you have any other suggestions/solutions for us? Thanks

Please see if the information in the following topic helps.
also, can you capture any packets from it on a host system?

Dear @aliqz9x5,
Could you confirm if you capture any packet data using wireshark on target?

Hi @SivaRamaKrishnaNV

I went through the information in the other thread but still doesn’t work for me.
Also, I confirm that there is no capture of data packet using wireshark. Please let me know if there is anything else I could try.

If you cannot capture any packets on the host system, I would suggest that you contact Continental to solve the problem first.

Hi @VickNV I have contacted Continental to provide the network IP, gateway IP address and network mask IP addresses but they replied that these are system related questions on how to configure your system outside the sensors, and should be addressed by the system manufacturer, i.e., Nvidia. So I am not sure what to do next!

Dear @aliqz9x5,
I suspect the issue with connection. Please verify the connection details once with Continental. Our engineer has tested connecting ARS430 RDI like ARS430RDI <= (BR interface connector <-> Molex RF coaxial connector) => AGX. At the AGX connect the Molex RF connector to the 100 Mbps Ethernet port above the camera group.

Hi @SivaRamaKrishnaNV
I confirm that our connection is correct and exactly like how you mentioned - the only difference is that we are using short jumper cables to connect to the ARS430RDI pins to the coaxial cable connecting to 100Mbps ethernet port, as shown in the picture. Do the think that the jumper cables can be an issue?