New install wrong libc6 libraries + more and cannot update it?

I was able to install the jetson 6 software on the sd, boot the drive, login and then use sdk manager to update the os. However, some of the liobraries are out of sync or something. I cannot install or upgrade Ubuntu due to these errors.
example:
sudo dpkg -i code_1.87.1-1709684532_arm64.deb
Selecting previously unselected package code.
(Reading database … 175277 files and directories currently installed.)
Preparing to unpack code_1.87.1-1709684532_arm64.deb …
Unpacking code (1.87.1-1709684532) …
dpkg: dependency problems prevent configuration of code:
code depends on libc6 (>= 2.28); however:
Version of libc6:arm64 on system is 2.27-3ubuntu1.6.
code depends on libgssapi-krb5-2 (>= 1.17); however:
Version of libgssapi-krb5-2:arm64 on system is 1.16-2ubuntu0.4.
code depends on libxkbfile1 (>= 1:1.1.0); however:
Version of libxkbfile1:arm64 on system is 1:1.0.9-2.

dpkg: error processing package code (–install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) …
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) …
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.60ubuntu1) …
Processing triggers for shared-mime-info (1.9-2) …
Errors were encountered while processing:
code
exampplpe 2:
vscode-linux-deb.arm64.deb 100%[=======================================================>] 88.60M 1.87MB/s in 46s

2024-03-12 14:25:46 (1.93 MB/s) - ‘vscode-linux-deb.arm64.deb’ saved [92899934/92899934]

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
code : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1.6 is installed
Depends: libgssapi-krb5-2 (>= 1.17) but 1.16-2ubuntu0.4 is installed
Depends: libxkbfile1 (>= 1:1.1.0) but 1:1.0.9-2 is installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

and yes, I tried running the fix commands.

Hi,
Please run the commands and check if the package is listed:

$ sudo apt update
$ apt list -a | grep libc

Jetpack 6.0DP(r36.2) has default rootfs in Ubuntu 22.04. Version of the packages matches with 22.04. So certain versions may be incompatible and cannot be installed.

there are a ton libcs listed
But for some reason the jetson 6 I downloaded installed ubuntu 18.04 and I was unable to perform a release upgrade. I since installed the sdk and I just tried the release upgrade again and it appears to be upgrading. I will update this post once completed by tomorrow.

Sorry for the late response.
Is this still an issue to support? Any result can be shared?

Hi, no was not able to correct 18.04 direct install issues, so I followed steps to uninstall chromium and upgraded to Ubuntu 20.04, which solved my problem. I was able to install visual code, nano and other apps without issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.