New jetson nano, appears to not be functioning properly

So i just picked one of these up, flashed the SD and it’s noticably slow and freezes on setup… eg… clicking “I agree” or continue has a 10-20 second pause and every time the mouse pointer is reset to the bottom right. i have the recommended SD card, tried multiple others with the same result. Multiple 5v 2amp power supplies and barrel jack power supply at 3a, double checked voltage drop and never goes below 5.10v under load (apparent load anyway). if i get passed setup, which IMO is painful… it seems to start working smoothly then just blank screen, doesn’t appear to auto-reboot or anything during setup. LED is still on. I remove power and power back up and it boots into the UI, shows the login name but then just loops forever with the name disappearing and reappearing with the mouse pointer being reset back to bottom right of the screen. if i re-install but with login on boot, it gets to the desktop but same issue is actions lock up for 5-10 seconds then resume. i tried different mouse/keyboard, wired and wireless, eithernet, no eithernet etc… same thing.

is this bad hardware or a bad software? the SD cards were benched as well to proper performance specs (80/30,90/40 mbps read/write). only thing i haven’t tried was a different OS/Image… this is with the official nvidia image so i assume this should be functional.

i figured i would double check here before i do an RMA for it.

Hi digibluh,

Which JetPack version are you using?
Are you using Etcher tool to flash image on SDCard or flash by sdkmanager?
Suggest you can change others sdcard and try again. Thanks!

Thanks for the reply. it’s just the latest SD card image via Etcher. i’ve tried a lexar and the recommended samsung card, both 32gb, same results. only other one i have is a sandisk i’ll try but since it locks up constantly in the UX, i feel like it’s just broken. last ditch i’ll see how it works headless. i have already tried 6 different power supplies and people seem to not have that issue using cell phone supplies so it might just be the board.

Please try to dump the serial console log.

https://elinux.org/Jetson/General_debug

I have the same problem, tried twice, no success, stucked at initial desktop setting screen, very slow.

module: B01 develop kit
SD card : sandisk 256G 160M/s
image: nv-jetson-nano-sd-card-image-r32.4.2

If this is very slow, I think we must need log from serial console. Please help dump.

i might try that later and see but i’ve RMA’ed mine and ordered another for now, but still have it. it should at least work with the basic “getting started” tutorial though.

Looks like the problem is with the latest image. I have downloaded the previous image and it works perfectly fine now. i had checked the MD5 of the latest image and it all matches, but appears faulty. that one was just posted on the 21st so i can see how it’s not reported yet.

This Image Works:
JP 4.3
2019/12/17

… go to the download center and flash that one

Yes, actually other forum users telling us this information too so we are still trying to resolve it.

For Jetpack 4.4 gpu issue, please try to apply this kernel patch.

seems unrelated. the latest image does not work and is impossible to do anything let alone patch the kernel.

Hi,

Actually, it is related. We have this gpu issue fixed with this patch.
The correct step here is to download the kernel source, follow up the cross compile steps in document and put the kerenl image into rootfs.

or you could wait until new sdcard image uploaded to the download center if you don’t want to do above patched work.

When will a new SD Card image be available as this seems to affect quite a few users?

Correct my previous comment. The sdcard image is already posted on the website. Could you help check?

Which web site? I am downloading an image now. What version should it be, what link are you referring to?

Hi,

We put everything in the download center. Please refer to the latest 4.4 version sdcard image.

Whenever we ask users to refer to documents, they are also on this website too.

And this is going to be different than the 4.4 image i downloaded over a week ago?

Both https://developer.nvidia.com/embedded/jetpack and https://developer.nvidia.com/embedded/downloads uses https://developer.nvidia.com/jetson-nano-sd-card-image as the Jetson Nano SD Card image download link.

That link still resolves to the same file name as “nv-jetson-nano-sd-card-image-r32.4.2.zip”. Is this an updated file? I would have expected a version bump?

If this is indeed updated, I will continue to download the almost 6Gb image.

1 Like

it’s the same md5 hash so no, it hasn’t been updated.

I downloaded the image just now and it does have a different modification date inside the zip file. The install wizard is running smoothly thus far. What day did you download the image last? it looks like the one i have that does not work was modified on 4/18/2020, and the file i just download the image has a modified date of 4/29/2020.
I can did a file compare as well, its definitely different than the image I downloaded a few weeks ago, but it was updated on the 29th. digibluh, are you having the same problems with this image?