New users can't use unity, only accounts nvidia and ubuntu work

Hello,

I’m using JetPack 3.2.1. When I create a new user, they are unable to use Unity. The unity desktop is missing the dashboard, window decorations, etc. The stock “nvidia” and “ubuntu” accounts work. This problem is similar to the one described in https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1758009.

I have tried replacing “unity-lowgfx” with “unity” in the ~/.config/compiz-1/compizconfig/config as well as clearing the .cache folder. However, each time a new user logs in, the “unity-lowgfx” attribute is re-inserted.

I have also tried enabling the Ubuntu Unity Plugin with ccsm, with no effect.

Thanks,

Try adding the new user to group “video” (this is required for GPU permission…this might or might not matter for this case, but it is easy to fix).

If you look at “/etc/group” you’ll see this line:

video:x:44:ubuntu,nvidia

You could just append the new user’s name to this (comma delimited). Another way would be to use usermod:

sudo usermod -a -G video <new user name>

After this the “video” line should have the new user name:

video:x:44:ubuntu,nvidia,the_new_name