newbie needs help please help

hi all:

this is copied over from my prev thread that was in the vista forums…i think i need it here so i copied and pasted it here (please ignore the thread in the vista forum)

have:
8800 gts 512 (G92)
nforce 4 kn8 ultra
vista 32 bit sp1 (and all updates)
nvidia vista 32bot driver 177.26 (it supports cuda)
JUNE 2008 DX runtime (i didnt see a june 2008 DX SDK)

im new to all this but have compiled a few linux kernels (thats about it)

here is what i have installed so far:
NVIDIA_CUDA_sdk_beta20b_XPVista32.exe
NVIDIA_CUDA_toolkit_beta20a_XPVista32.exe
NVIDIA_SDK10_Direct3D_10.11.0501.1720.exe
NVIDIA_SDK10_OpenGL_10.52.0215.1635.exe

Microsoft Visual C++ 2008 Express Edition

im not sure what im supposed to do about the DX SDK cause i have JUNE 2008 RUNTIME installed and the only DX SDK i see is from MARCH 2008.

also im not sure if i need anything else installed.

how do i setup Microsoft Visual C++ 2008 Express Edition?

i am stuck in this “CUDA_SDK_release_notes_windows.txt” at section I, step 4.

could someone make a complete guide to install AND setup Microsoft Visual C++ 2008 Express Edition so I can focus on actually learning programming instead of installing and setting stuff up?

I and probably others would be greatfull for this.

I know VC9 has to be setup correctly with inc and lib files and paths and i have no idea what i need to do there.

thanks for any help you can offer.

someone told me cuda only work with Microsoft Visual C++ 2005 Express Edition and not 2008 which i currently have installed.

im gonna uninstall 2008 and install 2005 soon but could someone or somemany please leave “detailed” instructions on how to get everything setup correctly inside of vs 2005

anything to help get a newbie started would be appreciated.

i figure after i get it up and running then i can focus on learning C and C++.
thanks again for any help.

http://forums.nvidia.com/index.php?showtopic=69183

that little app helped out alot but i dont think it configured direct3D SDK in VS 2005

i get these ERRORS when i follow the “CUDA_SDK_release_notes_windows.txt” in section “I” step “4” “- or use the global solution files release.sln or release_vc7.sln located in “NVIDIA CUDA SDK\projects”.”

note i had already installed the june 2008 dx runtime and i just now installed the march 2008 Direct3D SDK

so certain parts of the march 2008 sdk might not work with the june 2008 dx runtime…and then again it might all be working but i dont have something setup in the vs 2005

please help (more) :)

one more thing…is there an irc channel for #cuda?

i looked for #cuda on freenode and couldnt find anything.

come on guys…
i been on this a week and havent even got to a “hello world” ex: done yet.

can someone for the love of god help me get this thing setup and rdy to compile?

please…

missing windows.h says you dont have the PLATFORM sdk installed.

http://www.microsoft.com/downloads/details…&displaylang=en

It should also take care of the missing opengl headers.

If you want to test if CUDA is correctly configured, try to build the template sdk exemple (and only this one, you seem to be building the whole SDK) by right clicking it in the solution explorer window and then clicking build. Right click it again and click “set up as startup project”, then try to execute it (F5). See if that runs.

As for omp.h, you need to enable it on the project configuration: project, properties, c/c++, language, then “support openmp”

Ailleur:

thanks for the quick reply.

do i need that one or do i need one for vista 32bit?

It should also take care of the missing opengl headers.

i did what you said and the template sdk example seams to build and run fine but i did not try to build all the solutions like i did before.

when i tried to build all the solutions i was basiaclly just wanting to make sure i didnt get any errors that way i know i had everything configured correctly

here is my setup:

my apps i installed and dirs it created =

after i ran that “CUDA_VSExpress_Wizard1.2” my vs c++ 2005 “VC++ Directories” for "Execuatble files =

“Include files” =

and “Library files” =

i dont think i have all the inc and lib paths setup correctly and all software installed (like you said i dont have the platform SDK installed yet)

not sure if i need the one you provided in the link for windows server 2003 or if i need the one for vista in this link

vista platform sdk

idk

The app template wizard takes care of the include/lib directories on a per project basis. The SDK projects also make use of the $(CUDA_LIB_PATH) variable in every project. so you shouldnt need to touch the global visual studio settings.

As for the platform sdk, yeah i guess thats the one, i didnt pay attention to the fast that you were using vista when i posted it.

Im not a directX developper so i cant help you with that.

Good luck!

Ailleur:
when i build the templete.sln file located in “C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\projects\template” it builds and executes fines (dos box pops up saying its using my 8800gts and test “PASSED”

when i set that to “Set as StartUp Project” does that run everytime i open vs c++ 2005 with its own desktop icon?

i set it like you said but i dont think its loading up.

note: im still getting some errors when i try to build other project examples but some work ok.

after i startup vs c++ 2005:
File>New>Project
“i select cuda” and make sure "cuda winapp is selected
“console application” and “Precompiled header” are pre-selected and i just hit finish

i need to do that everytime right?

if i just open the vs c++ 2005 with its desktop icon (not open the cuda project templete) and try to compile “C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\cutil.sln” i get problems

------ Build started: Project: cutil, Configuration: Debug Win32 ------
Compiling…
cutil.cpp
c:\program files\nvidia corporation\nvidia cuda sdk\common\inc\stopwatch_win.h(37) : fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
stopwatch.cpp
c:\program files\nvidia corporation\nvidia cuda sdk\common\inc\stopwatch_win.h(37) : fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
stopwatch_win.cpp
c:\program files\nvidia corporation\nvidia cuda sdk\common\inc\stopwatch_win.h(37) : fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
Generating Code…
Build log was saved at “file://c:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\Debug\BuildLog.htm”
cutil - 3 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

the templete in “C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\projects\template” is different then the “File>New>Project
“i select cuda””

do i need to do just one of those or both?
note: that is with the vista platform sdk installed.

The CUDA SDK is made of many projects, so when you open release_vc7 (or something like that) you have a whole bunch of projects that open up. Setting the “template” sdk project as the startup project only means that when you hit F5 or click execute in visual studio, the executable generated from that given project will be launched or else visual studio wouldnt know which application within the sdk to launch.

You need to go through the application wizard every time you want to create a new project. When it is created, just load it up as you would with any other project by loading the .sln or by clicking it in the recent project panel when you launch visual studio.

I dont see why you wouldnt need to compile the cutil library since it is already available, compiled, in the /lib folder in /CUDA or in the sdk/lib directory.
As for the still missing windows.h, i dont know, i dont use vista so i dont know how to set it up.

well you have been a great help.
you are the only one who even attempted to help me.
thank-you very much.

with the info you have given me i gonna mess around with it for a bit and let it all sink in my head.
i want to say thanks again.

this is so funny…

look at this old thread.

this is where i left off along time ago and got frustrated…

since then i have had windows xp 32bit on this computer a couple times and also a coupld distros of linux…i got vista 32bit back on at the moment and GUESS WHAT…

IM GETTING THAT SAME ERROR AGAIN!!!

"Error 1 fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory c:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc\stopwatch_win.h 37

"

when i try and compile cutil like the “Quick Start Guide” says

now i know i got something not right here.

i have vista 32bit with all updates

Nvidia geforce 179.13

DX SEPT 2008 redist

CUDA 2.0 toolkit

cuda sdk

DX SDK

platform sdk

VS 2005 express

the VS 2005 exrpess wizard 1.2

and i still get this same exact problem…