Next-Gen debugger fails to start

I installed the latest driver for Nsight 5.5 in order to use the next-gen debugger, but unfortunately it’s not working. The legacy debugger is working fine.
I get the following message:
“Could not initialize driver for debugging.
Debugging has been automatically stopped.”

Windows: 7 Pro SP1
GPU: Quadro P6000
Driver: 388.59
SDK & Toolkit: 8.0
Nsight: 5.5.0.18014
Visual Studio: 2015 14.0.25431.01 Update 3

Extra info:

  • GPU for driving graphics is an AMD.
  • TDR is disabled.

Thanks,
Andreas

Hello,

Next-gen debugger only works under TCC mode, you must install 2 GPUs, one for display and use your P6000 as second card, then set it to TCC mode.

If your legacy debugger works well, I suggest you still to use it, nex-gen is for Tesla card, nex-gen will support wddm in next version of nsight.

Best Regards
Harry

Hi Harry,

I switched to TCC mode and it worked. I had already switched to using another card for the graphics. Thank you very much.

Best Regards,
Andreas

Hello,

I have the same issue - same error message, but this time with a Quadro in WDDM and a Tesla K20c in TCC. Legacy debugger is working fine as well.

Windows 7 x64
Nsight version: 5.5.0.1814
Driver version: 390.65

Any idea what could be the problem ?

Thanks,
Antoine

Are you sure the debugger is using the Tesla and not the Quadro for debugging?

I can only say that I’m never using the Quadro when selecting the device. Moreover, when running my application with the profiler, only the Tesla shows usage. Quadro context is never mentioned in any call.

Hello,

Next-gen debugger only work with pascal above card, so you cannot debug it on k20c, profiler should work on any device, could you please check if your app only runs on one GPU? I guess your app only use one card, you can set CUDA_VISIBLE_DEVICES to let it run on another card.

Best Regards
Harry

Hello Harry,

Thanks for the quick feedback. I supposed the requirement was stated on the page but I suppose I missed it.

I’m ok with the profiler behavior. I just don’t want to use the Quadro at all for CUDA.

Best regards,
Antoine

Hello there,

I’m facing the same issue here.
I want to debug a Windows CLI project. From http://docs.nvidia.com/nsight-visual-studio-edition/Content/Debug_External_Applications.htm I learned that that’s only possible with Nsight 5.5. However, I “only” have one GPU in my machine a no option to upgrade.

Does that mean, that I can’t debug a CLR project?

Yes, if you want to use next-gen debugger, you can use the legacy debugger to debug you cuda app, it can works on wddm mode

Thanks a lot for the answer. If I use the legacy debugger it doesn’t hit any break point.
I have three layers in my project:
.Net (CS) for testing
.cu for actual functions
and a C++/CLI layer to connect the two

While the standard VS debugger goes as deep as into the CLI layer before it loses track, Nsight (legacy) doesn’t hit any break point in any of these layers. I wonder if it’s because I didn’t tune the settings properly, or I’m using a late Windows 10 Pro Insider Preview Built (16299.248)? (referring to this thread https://devtalk.nvidia.com/default/topic/971720/nsight-visual-studio-edition/nsight-visual-studio-ignoring-break-points/)

The Next-Gen debugger throws “Could not initialize driver for debugging”.
Any thoughts?

My card is a Quadro K2100M btw… driver version 390.77 with Nsight 5.5.0.18014

Quaro K2100M is a kepler card actually GK106, I’m not sure if the latest nsight can work with it as we are only testing gk104 and gk107 now.

AFAIK, the legacy debugger can debug the .net exe + cuda dll, you must make sure that your cuda codes are contained in a local c++ not cli dll file, then use your .net exe to load it via DllImport.

You can set the bp in cuda dll then use legacy debugger to debug the .net exe, the bp should be hit.

Thanks a lot, I’ll try that,

would you generally say, that’s best practice for .Net and Cuda? I’m starting a new project so wouldn’t mind exploring a totally different work flow. I was looking into things like Alea GPU, managedCuda or altimesh, but can’t quite tell, which is the best bet in terms of performance and ease of development / debugging. I want to write something like a physics engine for .Net with minimal data transfer between host and device, so would like to have access to device memory to manage these things myself…

Sorry, my mistake, I just saw you only have on GPU, nsight cannot debug the CLR project, I’m afraid you cannot debug the code like managedCuda, nsight can only debug the code in local c++ project, the .net exe + cuda dll I told you before is actually the same thing, cu codes are contained in a local dll and the .net exe project is only a wrapper.

Okay thanks a lot anyways. I can’t avoid some messy work around then, but okay…
Best

I’ve got a similar problem.

I am running Win7/64 with dd 388.59.
I have a K620 in wddm. (this is a maxwell chip – GM107)
I have a TitanV in TCC.

I am trying to debug the cupti sass example. When I run the app without the debugger it says I am running on the TitanV.

I set a BP inside the kernel and run next-gen CUDA debugging. I get “Could not initialize the driver for debugging”.

I’ve looked over the prereq’s here and think I am compliant.

http://docs.nvidia.com/nsight-visual-studio-edition/5.5/Nsight_Visual_Studio_Edition_User_Guide.htm#System_Requirements.htm#Compute_Debugger_Support

Help?
–Bob

Looks like a driver issue, could you try the latest 391.01 driver?

Hi, I just installed 391.01. I got the same error message. I verified that NSight Monitor 5.5 was running.

Could you use “c:\Program Files\NVIDIA Corporation\NVSMI\nvidia-smi.exe” to check if your TitanV is under TCC mode? I remember only quadro and tesla can work under tcc mode.

Yep! It sure is … and has been for about 6 weeks.

Tue Mar 13 23:52:51 2018
±----------------------------------------------------------------------------+
| NVIDIA-SMI 391.01 Driver Version: 391.01 |
|-------------------------------±---------------------±---------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 Quadro K620 WDDM | 00000000:03:00.0 On | N/A |
| 36% 49C P8 1W / 30W | 406MiB / 2048MiB | 1% Default |
±------------------------------±---------------------±---------------------+
| 1 TITAN V TCC | 00000000:04:00.0 Off | N/A |
| 29% 42C P8 26W / 250W | 1MiB / 12160MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1796 C+G …n 5.5\Monitor\Common\Nsight.Monitor.exe N/A |
| 0 1980 C+G …6)\Google\Chrome\Application\chrome.exe N/A |
| 0 2036 C+G C:\Windows\system32\Dwm.exe N/A |
| 0 4028 C+G …ogram Files\Windows Sidebar\sidebar.exe N/A |
| 0 6680 C+G …sual Studio 14.0\Common7\IDE\devenv.exe N/A |
| 0 9884 C+G …sual Studio 14.0\Common7\IDE\devenv.exe N/A |
±----------------------------------------------------------------------------+