Nexus 7 in apx mode

Hello!
I’ve erased bootloader on my nexus 7 3g 32gb.
Now when I’m connecting my device to PC, It can be finded only as APX device.
Could you give me advice if there is a solution to make firmware or something for recovery my bootloader?
Help me, please.
Thanks!

I have the same issue and have been trying to sort it out for some time now. I have a nexus 7 8gb wifi.

Hi,
you can download latest google sdk and install google driver by sdk manager, then update the APX device driver with google driver, and you can find back your android device

if you erased your whole image
when you pick the driver you probably need the bootloader interface not the adb composite interface.

Hi, thanks for your help!
So, you mean android sdk? or is there some other google sdk?

hey!
Thank you for the answer!
if I pick the driver, where to get bootloader interface? )

I’ve downloaded Android SDK and installed all in SDK Manager but I couldn’t find any apx drivers there… so PC doesn’t recognize my device.

I don’t know how to install APX drivers for nexus 7 from Android SDK.
It means I do not understand something or Android SDK isn’t necessary SDK.

What to do? How to update APX device driver and find back my android device?
Thanks!

I’m assuming that you can boot up your nexus7, and just can not recognized by your pc, correct?

If so, boot up it and connect to your windows, open device manager, toggle the portable devices, you’ll see your device, right click to update/install driver software -> browser my computer for driver software -> let me pick from a list of device drivers on my computer -> have disk -> browser -> select android driver from sdk install folder, then install

hope that works:-)

also, if something like “android xxx interface” show under usb controllers on your device manager, uninstall its driver first, then it will show as unrecognized device, and install driver as the way i posted will bring your nexus back.

No, I can’t even boot up my nexus7! )
When I turn on my device it stops with google screen -> GOOGLE. That’s all.
In this condition, when I’m connecting my device to PC, It even CAN’T be finded as APX device.

if I turn off my device and then I’m holding all buttons together for some seconds, it can be finded as APX device on my PC but in this moment device has black screen.

I hope you understand what I mean =)

Thanks for helping!

ok, then you can try to update APX driver with NvidiaUsb.inf, which packaged in os images shipped by latest TADP.

Thanks a lot for your help!
I decided to send my device to a service center.
If they return my nexus back I’ll come back to ask more questions!

@jerryh_nvda

My N7 16gb Wifi is in a bootloop with CWM - happened when I tried to flash a new custom ROM. I can get it to APX mode. (I left the N7 alone for almost a year, so dont remember everything I tried). I think the bootloader needs to be updated before flashing the new custom ROM, the old bootloader apparently has a bug and I’ve downloaded a better bootloader version that supposedly doesnt have the bug.

When I power up, the black and white Google logo shows (unlocked bootloader) and then the CWM logo with Clockworkmod 6.0.4.3 and it restarts again and again. [ to stop it I have to disconnect the battery]

I would like to flash the new bootloader. How can I do it?

I tried looking for the drivers you mention, but I am overwhelmed by all the different devices and drivers being mentioned. (Also, I’m a little risk averse now :-( )

I would appreciate it if you could link to the drivers you mention and also tell me how I could flash the new bootloader. I have the latest Nexus Root Toolkit (v202), if that helps.

Thanks and I’ll let you know if everything works. [PS The local service center will not replace the device, so no way can I get my N7 working without trying what you suggest :-)

sorry, we cannot support such a condition. maybe your retailer can help

Thanks.
Its bricked then. :-(

Greetings,

I’m a bit new when it comes to making changes in mobiles and tablets. Seems like the Nexus 7 2012 32GB tablet is booting to APX mode similar to the others in this thread.

I’ll just give you a brief summary of events that unfolded. The tab was updated to the latest Lollipop 5.1.1 version available now and silly me tried to perform a clean install using the Fastboot option following the instructions given on the Google Developers Page. I’ve mentioned the link below.

https://developers.google.com/android/nexus/images

So while I’m following these steps, I got stuck in the middle when I saw this video on Youtube which showed how to use the Google Developer’s Instructions on the above link. Felt confident and I started the procedure when the progress got stuck in the middle after mentioning “Archive does not contain : Boot.sig & Recovery.sig”

https://www.youtube.com/watch?v=5ka5dnPghzI

So while this happened, I removed the device and used the Fastboot menu to start the device. It showed up as “Boot Failed”. So decided to follow the entire steps again and this time it actually went past the Archive does not contain message but there was an indication of a failed copy procedure after which it asked me to press any key to exit. So I had to abort this install even though i did not want to.

Next thing you know, the tablet is not booting up. Tried all the combinations----nothing!

So connected it back to the PC to check if shows some indication. Nothing there too. However, I noticed after a few glances through XDA, Android Central, etc that the tablet is in fact in APX mode and no ADB and Fastboot tool commands would work. I’m guessing there’s a way to load the fastboot back on to the device so that we can use it normally to flash the Lollipop 5.1.1 version.

Any help is very appreciated and if you need any other information…gimme a buzz! :)

Cheers!

I have the same APX problem. In my case, I flashed some archives and then I turned off my N7 while I was on the boot loader menu to continue next day…but it was stuck on APX mode. I live in Mexico, it’s annoying not find a functional solution for this tablet and this problem without sending an expired warranty tablet to Google or an expert.

Problem: I deleted 17GB big files from the storage and immediately force shutdown the tablet with holding the power-button.

After that the internal emmc got corrupted and is now in apx-mode…

Okey, here I am.

Today I took out my bricked apx-mode nexus 7 2012 from the shelve. I cleaned it from the dust.

I need help now. I have installed the apx-drivers on a windows 7 64bit.

I have the file nvflash.exe running in terminal.

I typed “nvflash.exe --wait” >>returned “UnKnown device found”

I don’t have the sbk-serial from the Nexus 7 2012 device.

I just need some quick steps or links for solution how to flash a new bootloader so I got go on.

I have those files:
1- bootloader-grouper-4.23.img(2 MegaByt’ish) ready for flash. Grouper is the code-name for the vendor-device recognized within google.

2- I don’t have any blob-backups. And I have another file that I don’t now what it is for >>flatline_grouper.img (7 MegaByti’sh)

3-wheelie.exe and a flatline(recovery) image for getting blobs. But the tablet is “Dead”

I need to repartition the whole emmc.

This is what I got in terminal:

nvflash --resume --down
load 4 C:\Users\hope\Documents\skräp\nvflash712\nvflash712\bootloader-grouper-4.
23.img
Nvflash started
[resume mode]
file not found: C:\Users\hope\Documents\skrõp\nvflash712\nvflash712\bootloader-g
rouper-4.23.img
failed executing command 2147483647 NvError 0x4
command failure: partition download failed

Thankful for the respons
I have many more working modern fast tablets at home. I just want to fix this in a technical way

/NvidiaDevKing

For more knowledge base what I am talking about is these pages:

1- SKB secure boot key
https://www.androidroot.mobi/pages/the-inner-workings-of-secure-boot-key-and-nvflash/

2- Tegra flash
https://www.androidroot.mobi/pages/guides/tegra3-guide-nvflash-jellybean/