Nexus 7 profiling call stacks unavailable

Trying to get the profiler working on my Nexus 7 (The correct, previous edition of the device) and running into a couple problems.

Question 1:

Following the profiler setup for Nexus 7 here:
http://docs.nvidia.com/tegra/index.html#Tegra_Profiler_deploy_Nexus_7.html

NVPACK\tegra-profiler\target\Tools\scanNdeploy.cmd isn’t working for me as it seems to be expecting to find a JDQ39 directory inside target\Tools.

Am I missing a step?

Question 2:
I was able to get the nexus 7 tools installed with some manual work
(Ended up running ‘deploy.cmd JDQ39’ from the “OSPatches\Nexus_7” directory, copying the quad_d file over to the device, and running quad_d as root)

Once installed the tegra profiler seems to work as expected. The one problem is that in the top-down view I’m getting no call stack information whatsoever for the hot functions:


I tried enabling the “show backtrace” option to no effect.

I understand from the documentation that sometimes call stack information isn’t available for specific functions, but is there something that could be preventing all call stack information from being available? Is this potentially an issue of something missing in my manual tools installation?

In case it is related, I see the following message in my quad_d log:
“[Wed Sep 4 13:28:53 2013] Static Tegra Profiler frames hooking is NOT supported.”

Question 1:
scanNdeploy.cmd and etc, is replaced by scripts which can be found in “NVPACK\OS Patches”
Question 2:
In order to keep the information needed for accurate sampling, your application needs to be compiled with the flags -fno-omit-frame-pointer and -mno-thumb. Additionally, in rare situations you may find incorrect function backtraces if the code was built with optimization. In the event that this is a problem, you may wish to build your code without optimization, for example: Application.mk: APP_OPTIM:=debug.

I’m also using a Nexus 7, but can’t get this far. I had to make some changes to the .CMD files to get everything deployed properly (to /data/data/com.nvidia.tegraprofiler). When I run quadd_d, the “.log” file shows this error:

[Thu Oct 10 12:22:31 2013] Tegra profiler (uid: 0)
[Thu Oct 10 12:22:31 2013] branch: Blackrock2, version: 1.39, build date: Aug 28 2013 at 13:06:46, build id: 1.2.16744070,151
[Thu Oct 10 12:22:31 2013] samples version: 16
[Thu Oct 10 12:22:31 2013] io version: 5
[Thu Oct 10 12:22:31 2013] load_quadd_modules (jni/…/Target/quadd_d/quadd_d/jni/qm.c:701): Error: can’t find module: kprobes_module.ko
[Thu Oct 10 12:22:31 2013] quadd_module_init (jni/…/Target/quadd_d/quadd_d/jni/qm.c:790): Error: load_quadd_modules
[Thu Oct 10 12:22:31 2013] main (jni/…/Target/quadd_d/quadd_d/jni/main.cpp:432): quadd_module_init error

The two “.ko” files are in the /data/data/com.nvidia.tegraprofiler/TegraProfiler/3.1.10-g05b777c, and I also tried copying them to the same directory as quadd_d, but got the same error. I’ve rooted this device, and am doing all this after a “su.”

What am I doing wrong?

BTW I’m using 4.2.2, JDQ39.