NFSv4 on jetpack 4.4

On jetson NX (actually also on Nano) i couldn’t mount NFS using version 4. It looks like we need to compile the kernel module. The error is “nfsv4 protocol not supported”. Note that other servers using 18.04 LTS x86 are able to mount the same exports using NFSv4

CONFIG_NFS_V4 is not enabled in tegra_defconfig. Please try to enable it first.

Thanks, where should I enable this? before building the image with SDKmanager?

Please download the kernel source from dlc and follow the instructions on L4T developer guide to build the kernel image.

Put the kernel image to Linux_for_Tegra/kernel and use flash.sh to reflash the board.

Ok let me give it a try. I will keep you posted

Great, it is working now.

@WayneWWW Since NFSv4 has been around for quite some time can you enable it by default in future kernel builds?

Most embedded systems don’t actually use NFS, and NFS, if unsecured, can be a security issue. I wouldn’t mind seeing this as a module (don’t know if this can be a module, have not checked), but it would probably be a bad idea if NFS were directly integrated ("=y") by default. Modules are easy to deal with, while removing an integrated feature is not so easy to work with.

Support for nfsv3 is already enabled as a module. The nfsv4 module should be enabled as well.