No 1600x900 resolution option in Linux Mint 13 Maya 64-bit w/ MATE

Hello,
I have been dealing with this for a while now. I have the latest drivers installed on my system (64-bit Linux Mint 13 Maya with MATE) and there is no 1600x900 resolution option for the display.
When I was using my on-board graphics card, I had found a work-around online by using xrandr. Now that I am using a GeForce for my display the xrandr trick isn’t working.
On another forum it was mentioned that the NVIDIA driver does not allow xrandr to alter the resolution, is this true?
I also have tried generating a xorg.conf from the NVIDIA x-windows control panel but this doesn’t work either.

Any ideas on how to add a 1600x900 resolution option?
This seems like such a simple thing but has been causing people so much frustration.

HI,

Take a look here:
http://us.download.nvidia.com/XFree86/FreeBSD-x86_64/270.41.06/README/xconfigoptions.html

and
http://forums.freebsd.org/showthread.php?t=23821

Specialy for mint/Maya I found:

http://forums.linuxmint.com/viewtopic.php?f=59&t=106990

I tried those but they did not work. Thanks for the help. Anyone else have an idea? I have a 16:9 dell flat-panel. I CAN set the resolution to 2560x1440 which fills my monitor but this is too high for me (everything too small) and would really like 1600x900.

May I suggest you give Bumblebee a try (http://bumblebee-project.org/install.html#Ubuntu)? Before installing it, you must uninstall your current Nvidia drivers. Please read this answer for instructions on how to do this and for more info:
http://askubuntu.com/a/36936/103814

For anyone interested… Solved by updating MINT to 17.2 and using Nvidia’s driver packages