No console after installing 515.65.01 on Alma 9/KDE

Hi, I have been struggling with this all week and I haven’t been able to sort it out. I have installed the Nvidia 515.65.01 drivers for my Nvidia 1660S in Alma 9 with KDE.

I think these are all related:
I don’t get a grub menu
I don’t see any boot messages in gfxterm
The monitor blanks (goes to sleep) if I systemctl isolate
The monitor blanks if I switch to a terminal like CTRL+ALT+F3

nvidia-bug-report.log.gz (313.2 KB)

Thank you for your time!

Reloaded on Rocky 9 with the same result. The greatest impact is I lost my alternate consoles.

All worked fine with Nouveau (except graphics are slow).
After installing NVIDIA 515.65.01 I have no consoles.

nvidia-bug-report.log.gz (252.6 KB)

I’m still working this issue. I have the same issue when running on default Gnome on EL9 as I do with KDE/X11 on EL9.

The console does not display. At boot time I have a cursor in the left corner. If I boot to, all I see is the cursor. However, I can log in and run a command (eg. sudo reboot) and it works. If I boot to, the gui works, but the virtual consoles have no video signal. I can log in to the virtual console and issue commands. I just can’t see anything.

Same issue with 515.76, 515.65 and 470.141.03.

Looks like you’re using CSM boot and your bios doesn’t provide a vga console. Please check your bios for an option to enable it or reinstall in efi mode, csm disabled.

Yes, you’re absolutely right. I stumbled onto this last night. The PCIe slot was set for UEFI bios, but the boot option was set to legacy. Setting boot mode to UEFI (as it should have been) and reloading fixes all of the above.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.