No cuda-capable device?

I know that this MacBook Air has a CUDA-capable GPU. I installed the Snow Leopard CUDA driver. It installed successfully – yet when I try to run code that uses CUDA it says that no CUDA-capable device is available?

Any help greatly appreciated!

Do you start in 32 Bit Kernel Mode ?

Until now the lastest CUDA drivers cant work in 64 Bit Kernel Mode = no cuda device found.

mitchde thanks for the good suggestion – I did not know if I’m running 32-bit or 64-bit kernel mode but it turns out it is 32-bit so that’s not my problem.

I forgot to mention that kexstat | grep “CUDA” outputs:

115 0 0x30263000 0x2000 0x1000 com.nvidia.CUDA (1.1.0) <4 1>

I tried reinstalling the driver and the toolkit, both installations claim success yet still no CUDA device found. :|

The same thing happened to me today actually. And I’m sure everything was working a few weeks ago. But today I couldn’t find any device. I re-installed everything (driver and toolkit), restarted my Mac (even if I wasn’t asked to do it). And everything was back to normal again. When I re-installed, I used CUDA 3.0 though. Which wasn’t available to you at the time (at least not the final version). So if you’re still having issues, you might want to try with CUDA 3.0.

Just a quick precision, I have a Macbook Pro running 10.6.2…

Hopefully you found a solution by now.

But if not, I had a similar experience recently:

Between the uninstall and reinstall, did you reboot? Kextunload does not work after the uninstall.

Alternatively, kextunload first (and verify) then uninstall, then reinstall.

Hope this helps.