No CUDA-compatible devices have been found...

I am trying to run a software program which uses a GPU to run a calculation. However, upon starting the calculation, I receive an error message that says “No CUDA-compatible devices have been found”. I checked that my GPU (Quadro 600), driver (390.67), and CUDA toolkit (9.2) are all compatible with the software, and they are. So I assume it is something I have done with the installation process.

I first installed the CUDA toolkit with the .run file obtained on your website for CentOS 7 and performing the “sudo sh <run_file>.run” command which was successful (with checking the GPU requirements, installing kernel packages prior).

I then downloaded the driver .run file based on the file provided on your website for the Quadro 600 GPU. This was done by first disabling the nouveau driver, logging out of the X session into text mode, installing the driver with “sudo sh .run”, which alerted me that it was successful and I rebooted my machine.

I then added “export PATH=/usr/local/cuda-9.2/bin${PATH:+:${PATH}}” to my .bashrc file and also “export LD_LIBRARY_PATH=LD_LIBRARY_PATH:/usr/loval/cuda-9.2/lib64” since LD_LIBRARY_PATH already was created for the software package internal libraries (note: I have also tried to put “export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64\ {LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}” in my .bashrc file alone and this resulted in the same error message)

I then turned on persistance mode for my GPU and disabled the udev rule as outlined on the post installation steps provided by NVIDIA. Running a quick “nvidia-smi” shows that all of these installs have seemingly worked, yet the software package is not able to find any CUDA-compatible devices.

The Quadro 600 is a GPU based on the Fermi architecture, with compute capability 2.1, released ca. 2010. As such, it is not supported by current NVIDIA drivers, or current versions of CUDA. It is simply too old.

I would suggest installing more recent hardware to replace the Quadro 600 (which you would want to turn over to an approved e-waste recycler). The minimum architecture supported by current software is the Kepler architecture with compute capability >= 3.0. I would suggest upgrading the hardware, preferably to a GPU in the Pascal family. If you need to stick to Quadro cards, the entry-level Pascal GPU is the Quadro P600 that retails for around $180.

I have recently updated my GPU to a TITAN V, which is using the 390.87 driver and the cuda 10.0 toolkit, yet I am still receiving the same error or “No CUDA-compatible devices have been found in your system” upon starting a calculation

390.87 will not work with the CUDA 10.0 toolkit