No Cuda Device Enabled

I’m running Fedora 11 From uname -a I get:
Linux #1 SMP Wed Jul 29 16:02:42 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

and when I run the deviceQueryDrv binary i get
Device 0: “Tesla C1060”
CUDA Driver Version: 2.20

Device 1: “Quadro NVS 295”
CUDA Driver Version: 2.20

but deviceQuery returns “No CUDA device enabled.” and bandWidthTest seg faults.

I have nvida0, nvidia1, nvram, and nvidiaactl in my /dev directory However

rpm -qa | grep nvidia d

oesn’t return anything.
Is this an issue with my kernel? Is there any way to fix this or should I just reinstall the toolkit, then the driver, then the sdk and keep my fingers crossed?

Are you sure that you install CUDA driver? I’ve get the same error because I do not install the driver. Be careful with the graphics driver. They do not turn you able to use the CUDA capability of the GPU.

Hope this will help you.

Yep the admin rebooted the kernel and only installed the graphics drivers. I had to reinstall the cuda driver.

Thanks very much for the help.