No cuda trace on tensorRT C++ Windows x64

I am trying to profile the tensorRT on C++ Windows x64.
Even though I selected CUDA, NVTX before start profiling, I was not able to collect the trace from Gpu.

Below are the headers, memory usage during runtime, and the result of the profile.
The cuda, cudnn, tensorrt .lib, and .include files as well as paths are added through the project options from visual studio 2019.
However, I did not configured dependency on Cuda in visual studio 2019.

Should I add other codes to my application?

Also, When I run the profile, the running process seems to end very quickly. Thank you.


Figured out that the TensorRt engine was loaded,
but the input that propagated through the networt was not initialized with values.

After initializing input with the values I was able to see the cuda trace.

I am sorry that there was no response to this earlier, your forum post was dropped in an orphaned category that the Nsys team was unaware of until this afternoon.

I am really glad that you solved your own problem.

1 Like