No debian package for 32.7.2 in apt repository

Hi,

L4T 32.7.2 has been released, but there are no 32.7.2 packages in the apt repository.

$ sudo apt update
Hit:1 https://repo.download.nvidia.com/jetson/common r32.7 InRelease
Hit:2 https://repo.download.nvidia.com/jetson/t186 r32.7 InRelease     
...snip...

$ apt-cache policy nvidia-jetpack
nvidia-jetpack:
  Installed: (none)
  Candidate: 4.6.1-b110    <--- Expect 4.6.2
  Version table:
     4.6.1-b110 500
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages

$ apt-cache policy nvidia-l4t-jetson-multimedia-api
nvidia-l4t-jetson-multimedia-api:
  Installed: (none)
  Candidate: 32.7.1-20220219090344    <--- Expect 32.7.2-20220417024839
  Version table:
     32.7.1-20220219090344 500  
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages

The following packages are not provided by BSP and are specifically needed.

  • nvidia-jetpack
  • nvidia-l4t-jetson-multimedia-api

The other nvidia-l4t-* package also does not exist 32.7.2 version.

Any plans to upload them?

Best regards,

For L4T R32.7.2, the only change came with the BSP for PSIRT fixes, others are the same as L4T R32.7.1, AFAIK, there is no plan to update relevant documents or packages.

@kayccc

32.7.2 cannot install nvidia-jetpack. Is it a spec?
Please upload the 32.7.2 debian package to the repository.

BSP for 32.7.2 cannot install nvidia-jetpack because nvidia-l4t-camera 32.7.2 is installed.

$ apt  install nvidia-jetpack
...snip...

The following packages have unmet dependencies:
 nvidia-l4t-jetson-multimedia-api : Depends: nvidia-l4t-camera (= 32.7.1-20220219090344) but 32.7.2-20220417024839 is to be installed
                                    Depends: nvidia-l4t-multimedia (= 32.7.1-20220219090344) but 32.7.2-20220417024839 is to be installed
                                    Depends: nvidia-l4t-multimedia-utils (= 32.7.1-20220219090344) but 32.7.2-20220417024839 is to be installed
E: Unable to correct problems, you have held broken packages.

nvidia-jetpack 4.6.1-b110 depends on nvidia-l4t-jetson-multimedia-api (>> 32.7-0, << 32.8-0).

$ apt show nvidia-jetpack
Package: nvidia-jetpack
Version: 4.6.1-b110
...snip...
Depends: nvidia-cuda (= 4.6.1-b110), nvidia-opencv (= 4.6.1-b110), nvidia-cudnn8 (= 4.6.1-b110), nvidia-tensorrt (= 4.6.1-b110), nvidia-visionworks (= 4.6.1-b110), nvidia-container (= 4.6.1-b110), nvidia-vpi (= 4.6.1-b110), nvidia-l4t-jetson-multimedia-api (>> 32.7-0), nvidia-l4t-jetson-multimedia-api (<< 32.8-0)

nvidia-l4t-jetson-multimedia-api 32.7.1 depends on nvidia-l4t-camera 32.7.1.

$ apt show nvidia-l4t-jetson-multimedia-api
Package: nvidia-l4t-jetson-multimedia-api
Version: 32.7.1-20220219090344
...snip...
Depends: cuda-cudart-10-2, cuda-cudart-dev-10-2, libc6-dev, libglvnd-dev, libx11-dev, nvidia-l4t-camera (= 32.7.1-20220219090344), nvidia-l4t-multimedia (= 32.7.1-20220219090344), nvidia-l4t-multimedia-utils (= 32.7.1-20220219090344)
...snip...

You should be able to see the JetPack 4.6.2 for L4T R32.7.2.

@kayccc
No, only nvidia-jetpack 4.6.1.
Please upload nvidia-jetpack 4.6.2 and 32.7.2 debian package to the repository.

$ sudo apt update
Hit:1 https://repo.download.nvidia.com/jetson/common r32.7 InRelease
Hit:2 https://repo.download.nvidia.com/jetson/t186 r32.7 InRelease 
...snip....

$ apt-cache policy nvidia-jetpack
nvidia-jetpack:
  Installed: (none)
  Candidate: 4.6.1-b110
  Version table:
     4.6.1-b110 500
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages

Hi nomotoh3v2z,

We will check apt install issue.
Please use SDK Manager to install sdk components first, it’s working.

@carolyuu
Thank you for your support.
I am unable to use the SDK Manager because I am using a custom board.

Hi,
You should be able to install SDK components through SDKManager for custom board. Please give it a try.

@DaneLLL

sdkmanager requires flash.
OTA updates are not possible and require physical access.

Please upload jetpack v4.6.2 to the repository so that OTA updates can be done. Just like any other L4T version.

Hi,
You can skip flash and install only SDK Components. Please try this.

@DaneLLL

In any case, sdkmanager requires a host PC.

L4T 32.7.2 cannot update jetpack on the device. This differs from other L4T versions.
We need a package in the apt repository that matches the L4T version.

Hi,
Our teams are checking the issue. Will update.

Currently for installing SDK components, please install through SDKManager.

apt server has updated and has 32.7.2 package now. Please try.

1 Like

@WayneWWW

I have verified that the package uploaded as expected.
Thank you for all your assistance.

$ sudo apt update
Hit:1 https://repo.download.nvidia.com/jetson/common r32.7 InRelease
Hit:2 https://repo.download.nvidia.com/jetson/t186 r32.7 InRelease                                                                                                 
...snip...

$ apt-cache policy nvidia-jetpack
nvidia-jetpack:
  Installed: (none)
  Candidate: 4.6.2-b5
  Version table:
     4.6.2-b5 500
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages
     4.6.1-b110 500
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages

$ apt-cache policy nvidia-l4t-jetson-multimedia-api
nvidia-l4t-jetson-multimedia-api:
  Installed: (none)
  Candidate: 32.7.2-20220417024839
  Version table:
     32.7.2-20220417024839 500
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages
     32.7.1-20220219090344 500
        500 https://repo.download.nvidia.com/jetson/t186 r32.7/main arm64 Packages
1 Like