No device supporting CUDA - GeForce 7900 GTX No device supporting CUDA - GeForce 7900 GTX - Visual S

Hi there,

I have a GeForce 7900 GTX, Windows XP and installed CUDA 1.1 (CUDA driver 169.21, toolkit, sdk). I followed the instructions I found in this forum and even installed the wizard for Visual Studio 2005 (really cool!!!) but when I run deviceQuery (sample project) I get a message “There is no device supporting CUDA”. The message is below:

Device 0: “Device Emulation (CPU)”
Major revision number: -1
Minor revision number: -1
Total amount of global memory: -1 bytes
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 32
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 1350000 kilohertz

It makes sense, since these messages are about the Device Emulation and not my GeForce card… I found other posts here with the same problem, and tried a lot of things like uninstalling and installing again different versions of the drivers, toolkits etc but nothing worked. Isn’t the emulation device supposed to be able to run CUDA programs? Is there sth I can do so that Visual Studio 2005 can see my GeForce card?

Thanks!

This card is indeed not CUDA-enabled. G80 (8800GTX and such) and higher are supported

Thank you Denis for your quick reply.

Hm… perhaps I misunderstood then. When I downloaded CUDA 1.1 from nVidia official site, GeForce 7900 GTX was in the list with “Products Supported”, what does that mean?

Does anybody know if there is a way to use the “Emulation Device” to run cuda programs from Visual Studio 2005? I think the problem with the emulation device is that “Major revision number” = -1 and “Minor revision number” = -1, is there sth I can do about that? Is this correct?

Which list were you looking at? This is is a pretty comprehensive list:

http://www.nvidia.com/object/cuda_learn_products.html

I was looking at the list: http://www.nvidia.com/object/winxp_169.21_whql.html (2nd tab -> Products Supported). Thanks.

So I suppose I have to use the emulation device. Does anybody have any idea why its “Major revision number” and “Minor revision number” values are -1?

Ah, now I see. That’s just the video driver support list. CUDA has been integrated into the main NVIDIA drivers, but not all cards supported by the drivers also have the hardware required to run CUDA programs.

As for the -1, I assume that is a placeholder to indicate that the emulation “device” is not a real card. I don’t think the -1 is the source of your problem, but I don’t do CUDA development on Windows, so someone else should jump in here.

Emulation device can run CUDA programs only if you compile with -deviceemu specifically.