No display / NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver

I have two kinds of problems depending on what I tried.

1.NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver.

I have tried (based on several forums):
1a. sudo apt purge nvidia*
1b. install nvidia driver from Software & Updates > Additional Driver. Select nvidia-driver-470 (proprietary, tested) [also have tried other version too, e.g. nvidia-driver-510 or nvidia-driver-515 after purging]
1c. remove /lib/modprobe.d/blacklist-nvidia.conf
1d. sudo prime-select nvidia
1e. confirmed installed status from dkms status
1f. reboot. Then it goes to the problem number 2

  1. Can boot but no display. Just black screen with one underscore white cursor. Can enter tty. Logged in, nvidia-smi works well here. Can return to problem number 1 if sudo prime-select intel then reboot. Also, problem 2 will not happen if I didn’t (forgot to) delete /lib/modprobe.d/blacklist-nvidia.conf (but problem 1 persists in this case)

Attached is the bug report that I generate in tty during problem 2.
nvidia-bug-report.gz (303.1 KB)

1 Like

Thank you for your quick response.

I upgraded to new kernel (I think…), with these commands:

sudo add-apt-repository ppa:damentz/liquorix && sudo apt-get update

sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

For the firmware, I did
sudo apt-get install linux-firmware although none is newly installed

I still have the same problem.

Here is the new bug report from tty
nvidia-bug-report.gz (283.7 KB)

Please remove “nomodeset” from kernel cmdline.

Thank you!

The problem is solved now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.