No Display Output When NVIDIA Driver Installed - Ubuntu 22.04.1


I run an HP Z420 Workstation with 2 GPUs: a Quadro 2000 and an RTX 2060. A while back, this configuration worked fine, however I had done some KVM GPU pass-through with the 2060 which required disabling kernel modules for the GPU. I have since removed all these files that disable the drivers (at least I think!), however the 2060 only outputs display with the Nouveau drivers; as soon as I install any version of the NVIDIA drivers from either the command line or the “Additional Drivers” tab from the GUI app nothing shows.

I’ve purged drivers many times, ensured secure boot is off, deleted blacklist files, and much more—nothing seems to be working. I’m assuming the issue is something that I did earlier, and now am overlooking, but I have been trying for a few days now and I’m getting desperate for answers.

I appreciate any help, thank you in advance!

nvidia-bug-report.log.gz (134.0 KB)

Wrong driver. Please use Software & Updates to switch to the non “-open” driver version.

Hi, after purging all NVIDIA packages and then installing nvidia-driver-530 through Software & Updates, I am now getting no display output from either cards. Here is a new log file I obtained over SSH:

nvidia-bug-report.log.gz (341.5 KB)

The old quadro is set as primary graphics but only supported up until driver v390. Please remove it from the system. Furthermore, please blacklist nvidiafb.