No Graphic Ubuntu Welcome Screen, Monitor says "No Signal", Xorg 100% cpu Stucked.

Thank you for reading, and here’s my problem:

When i turn on the machine, sometimes i can not get the Ubuntu Welcome Screen, and the Monitor says there is “No Signal” and turn black.

[What i have tried]

My computer has sshd services installed, so I ssh into it and see what’s going on.

With ps -aux | grep Xorg, I have this output:

root 961 99.6 0.3 136828 27572 tty7 Rs+ 09:23 32:46 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

I have noticed the STAT is R (Running). I tried to use sudo kill -9 961 to kill the process, it didn’t response anything, so maybe it stucked in some system calls.

And I cat the /var/log/xorg.0.log, I have this:


[ 27.467] (II) NVIDIA: Using 12288.00 MB of virtual memory for indirect memory
[ 27.467] (II) NVIDIA: access.
[ 27.587] (II) NVIDIA(0): Setting mode “DFP-2:1920x1080”

And the log just stucked here. normally something like ’ (==) NVIDIA(0): Disabling shared memory pixmaps ’ should come next, but no. So I guess the problem is related to the nVidia driver.

My nvidia driver version is 367.57, and I remember when I use the older version earlier, this problem was also there.

[ How I reproduce this problem ]

If I shutdown from Ubuntu properly, and after a few minutes, press the “power” button, and the problem probably will show up.

After the problem shows up, I press the “power” button for 5 sec to force the machine to shut down and then press the “power” button again, it probably give me the Ubuntu login screen and I can use the computer for hours without any display problem.

If I reboot in Ubuntu using reboot command or Restart button, everything goes well, and I can continue use it for hours.

Any suggestions will help, thank you.
nvidia-bug-report.log.gz (199 KB)

ps, The nvidia-bug-report.sh was run through ssh when the problem occured.

I have no idea of how to solve your PC’s problem, LiuSida. But supplying its detailed system specs. may help others to do so.

OS & kernel version?

Hardware?

Did this issue arise shortly after installing a new graphics card?

Is there a firmware / BIOS update available for the card?

If possible, have you tried connecting the monitor to the graphics card via different methods (DP, HDMI, DVI-D DL)?

Is your PC motherboard’s BIOS / UEFI up-to-date?

Are you using alleged ‘Secure Boot’ or are you using the Compatibility Support Module?

Has the motherboard’s RAM been tested?

Have you tried a different HDD or SSD?

JGB123321,

I have found the tool nvidia-bug-report.sh has collected almost all the information of my computer, and the result has been attached above, so I don’t list them out in the post.

But it still worth to say that I have Win10 installed beside Ubuntu, and that os never have any noticeable problem with the graphic card, so I guess the hardware has no problem.

Thank you for guiding me to this board.